Could not open a connection to the CEC-Adapter

Hi out there,

at monday my vero v and my cec-remote worked like charm for about two weeks.
Yesterday I got the error (see above).

TV: LG (‘old’ plasma)

I rebooted already, but there is no change…

Does anyone know what I can do?


Try another HDMI cable and try power everything off at the mains for 5 minutes.

Ok, thanks, but that didn’t work.

But I managed to to get it back again by

  • stopping mediacenter;
  • moving .kodi to .kodi.old;
  • extracted old settings (formerly rpi4b) to .kodi and
  • started mediacenter again.


I’d guess that you could probably fixed it then with…

systemctl stop mediacenter
rm ~/.kodi/userdata/peripheral_data/cec*
systemctl start mediacenter

although I really don’t know how that file would have gotten messed up or changed on its own out of the blue.

The file guisettings.xml from a RPi should not be restored to a Vero.

After every restart my Vero V loose CEC connection with my LG B2 TV and there is information about this in right upper corner. I need to turn off my tv and soundbar for 5-10 minuts and then everything works to another restart.

There is also annoying bug with oryginal remote but there is whole another topic at this forum.

I must say that VERO 4k worked a lot better in this area.

I have tried 3 cables. Same situation :frowning:

Please do something with this issue

Hi @lukcinek - are you also getting the same error message ‘Could not open a connection to the CEC adapter’?

Some logs from you would be useful

The CEC implementation on Vero 4K and Vero V are identical.

He Sam,

I think I get te same error but now it works because I turn off tv and Vero for 1h.
I confirm error message next time it occur.

Best regards

I will need to see some logs to advise.

Ok, today a restart of mediacenter brought it back - Pulse-eight ‘Could not open…’

I setup Debug-log to libcec, hopefully there is something to see:


Thanks. I will check this shortly.

Hi folks,

I changed HDMI-cable to different 4K/8K-ones - no chance to get cec established.


Now I tried to configure a Samsung GU43TU8079UXZG on different HDMI-Ports. Vero V is recognized and running. First it didn’t work, but after I stopped/started mediacentger again, i managed to get it to work directly at TV-HDMI1.
My Onkyo RZ50 is able to communicate with firestick by cec but does not show anything about vero, so I couldn’t make it to a master/center.
If someone uses an equal setup, I’d love to learn how to combine all things working with one remote - even the RZ50.


Perhaps the issue isn’t the ports on the Samsung but on the AVR


Actually I’m dealing with an issue due to this up/down-switch right from volume-switch. If one accidently touches it, tv tries to change programms from TV - not from vero/kodi.
I know, I have once sat this remote to work with up-/down with Kodi, but do not remember. I tested to much today.


Did you physically unplug the Vero, TV, and any other HDMI connected devices from the wall for a minute before powering them back on to completely reset the CEC bus? In that log it is showing the Vero as trying to assign itself to one of the tuner device names but all of them are taken up. This sounds to me like something got old assignments stuck and isn’t letting them go. Maybe something on the bus has a bad connection and is disconnecting and then reconnecting as a new device? Also I wasn’t seeing an amplifier type CEC device registering either. I wonder if it isn’t just the Vero that isn’t happy here.

Yes I did - and it 's working with this minor issue - up-/down-switch call native TV-programs…


That is most likely a function of your TV. OSMC only can work with the keys that are transmitted to it via CEC.

1 Like