'Couldn’t connect to network server'

I got the Vero 4k recently and I initially had no issues setting it up and connecting it to my NAS’ UPnP server, and playback was fine.

The second time I used the Vero it ‘couldn’t connect to network server’. I then tried zeroconfig and was able to connect to the NAS’ home directory but opening any subfolder led to a ‘file exists’ error.

I just installed the January update and the problem still persists.

What am I doing wrong?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I just downloaded the second January update and that seems to have magically fixed the issue :man_shrugging:

@sam_nazarko and the issue is back.

My Vero is connected to the Marantz NR1607, which is connected to my Sony KDL50W800B TV.

My source is a QNAP TS251 and all devices are connected to a Netgear GS724Tv4 switch.


Does the NAS have a static IP?

UPNP and Zeroconfig might not be the most reliable solution. I suggest you mount the drives via SMB directly.


Mounting via SMB leads me to the ‘File exists’ error. Why support UPnP if it’s not reliable?

What is the ‘File exists’ error? You would have to explain what you have done and share debug enabled logs.
UPnP works for some people but surely it is not the sharing technology I would suggest to use.

Read the OP and link I shared 2 hours earlier.

Ask Kodi developers. Makes little sense to us as well. OSMC always recommend NFS (preferred) or SMB as they are much more robust.

Did you tried to change Max Protocol Version to SMB1 and than add the SMB Share as source?
I suggest to first clean your library and then try to add that way and if problem remains provide debug enabled logs afterwards.