Crackling sound with some HD Audio files on a Sony 5.1

And could you please look for the exact model number again? Am I understanding correctly that this is an all-in-one BD player and speaker system - so, no AVR involved here?

1 Like

Yes, it’s an all in one type thing, so the Blu Ray player is actually the receiver. It’s supposed to be DTS capable, Dolby Digital SS and DTS-MA capable

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks Sam, is this going to be included in a forthcoming update? If it is, I’ll just wait until then.

It will be, but we like to get feedback as we don’t have a roomfull of different AVRs to test. Yours is not ‘mainstream’ so if you have time it would be good if you can test. Please leave it an hour or so, though, because a new build is in progress as we speak.

Do you have the actual model name for us? It sounded like you weren’t completely sure about it in the original post…

Hi, it’s a BDV-E280. I will struggle to test it this weekend, young kids and all that.

FYI, Your support and response time is excellent. Thanks guys.

So, the solution is what I’ve already expected it to be… The HDMI-in ports of that BD player can’t process HD audio. This is from the BDV-E280’s manual:

So, you should set you audio settings to the following:

Audio device: HDMI
Number of channels: 2.0
Output configuration: Best match
Passthrough: enabled
DTS/AC3 passthrough: enabled
DTS-HD/TrueHD/E-AC3 passthrough: disabled
AC3 transcoding: enabled

And keep in mind to disable “sync playback to display” under settings/player/videos for passthrough to work.
If you want your TV’s refresh rate to be adjusted according to the source’s frame rate, also set "Adjust display refresh rate” to Always or to On start/stop under settings/player/videos. :ok_hand:t2:

The crackling sound is most likely resolved in the next update. If you want to check it out already now: go with Sam’s advice in post #15.

If this issue is resolved for you with this advice, please mark the corresponding post as the solution for other users to easily see the solution for your initial issue. :+1:t2:

1 Like

Thanks. So are you saying that I won’t be able to get 5.1 surround sound at all - as I have to set everything to 2.0 ?

It won’t get more than 2.0 LPCM as stated in the above excerpt from your device’s manual. The only bitstreaming formats supported are AC3 (Dolby Digital) and DTS.
If you configure the Vero as advised, you’ll get sound no matter what you play: HD audio formats will pass on the core audio (DTS for DTS-HD formats and, if present, Dolby Digital for TrueHD or E-AC3) or transcode the audio to AC3 on the fly (e.g. for all LPCM audio above 2.0). That’s the best that can be done with your AiO BD player :+1:t2:

Ok, thanks for the advice and your support

Please mark this as solved if it’s working for you. There is no need to test the alternative - it should just work with OSMC as currently installed and @Chillbo’s suggested settings.

Thanks, it seems to be working ok for now. Not had a crackling sound since going to the new settings. One question: I don’t suppose using an “optical” lead for the audio would lead to any improvement in audio quality?

Unlikely. We have never had any reports of ‘crackling’ on optical but this is now fixed on HDMI.

Sorry to open this thread up again but I have a question - When using that Sony 5.1 surround sound system - it doesn’t seem to process 4k files through the Vero to my TV. It keeps them at 1080p . Is there anything I can do to get round this? Some sort of adapter or such? Or am I bang out of luck and stuck with my TVs audio for 4k files?

Thanks

This might help you:

1 Like

Thanks for that. I may go down that avenue as a last resort - but I was thinking - is it possible for me to do this:

-Connect the Vero 4k to the TV directly by HDMI for video
-Connect the Vero4k to the Sony 5.1 via optical for audio

?

Of course you can. But you’ll just get the non-HD audio formats supported by S/PDIF. The rest will be sent as the lossy core or transcoded to AC3 5.1.

Thank you again. I will try this first. Can you advise what settings I should have on the Vero4k to make this work? i.e. - what options in audio output and which of the formats i should have ticked? thanks again for your time.

You should set them to the following:

Audio device: PCM
Number of channels: 2.0 (S/PDIF only supports 2 channel LPCM)
Output configuration: Best match
Passthrough: enabled
DTS/AC3 passthrough: enabled
DTS-HD/TrueHD/E-AC3 passthrough: disabled
AC3 transcoding: enabled

And keep in mind to disable “sync playback to display” under settings/player/videos for passthrough to work.
If you want your TV’s refresh rate to be adjusting according to the source’s frame rate, also set "Adjust display refresh rate” to Always or to On start/stop under settings/player/videos.

1 Like