Crash and Reboot during startup


I don’t know if there was an update today, which caused this problem, but the Vero woke up alone and I saw at searching for updates. At least an update for a SNES controller was installed. Maybe more updates which caused this problem.

Since then I have the problem:
System starts up, starts to scan library and crashes, and this is now in a loop.
It checks movies 96% and then Series and instant crashes.

Also w/o a connection to the NAS or when I rename the folder of the files.
Also no new entries have been added and before it was working.
I was quick enough to disable scan on startup, but it still crashes.

I’m using a Vero4k.

best regards

Managed to pull Logs: - newest


Usually if Kodi crashes during a scan, it’s due to a corrupt file.

Can you get full logs with debugging enabled?
You can start Kodi and perform a scan and upload logs after it comes back


Hi Sam,

I managed to disable the scan on startup, but it still crashes, not it seems not to be a scan problem.
Since I’m a newbie on Linux, how can I get you the logs with debugging?
Since Kodi is crahsing quick, I’m not sure if I can start a scan?

Via SSH, you could run grab-logs -A. This will give you a URL.

It must be a capital A

grab-logs -A

Try to disable the Upnext Addon and see if it makes a difference

Can I do this via SSH?
If yes, with which command?


You would first need to find the folder ls .kodi/addons/ then you can remove it with rm -R .kodi/addons/<name of the folder of the addon>

Thanks, did that and it was not listed after I resend the list command, so it was removed, but it still crashes.

Heres a new log from the last startup:

Actually it crashes with a segmentation fault
/usr/bin/mediacenter: line 216: 2947 Segmentation fault

  1. You could try with a clean Kodi folder (see below)
  2. Try to reinstall Kodi sudo apt install --reinstall vero3-mediacenter-osmc

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2


tried that, inbetween it showed a different Mediacenter, so it seemed to work (no crash on this level), but when I copy the original folder back, it crashes again.

Also the reinstall didn’t work.

I assume the next step would be a complete new install? Can I save my settings and maybe watched status and import this in the new install?
Or are we maybe talking about Hardware problems? SD Card broken?

Well I would assume a different Skin as the Mediacenter (Kodi) is always the same).

Well you could dissect a bit further.

  1. Try to remove guisettings
systemctl stop mediacenter
rm .kodi/userdata/guisettings.xml
systemctl start mediacenter
  1. If step 1 didn’t work try to remove all addons
systemctl stop mediacenter
rm -R .kodi/addons/
systemctl start mediacenter

I doubt that if it worked with a clean Kodi folder. Also FYI you are using a Vero that doesn’t have an SD Card but an EMMC which is quite unlikely to fail.

  1. step no success
  2. step success, at least no crash anymore, so one of the addons was corrupt?

Thank you very much, need to set up the configs again a bit, but less work, than a complete install :slight_smile:
Edit: after changing back to the Skin I used, I only needed to calibrate the display, everything was fine :slight_smile:


You should not need to do that EVER see recommendations below!

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

Thanks, did that on my Samsung :slight_smile:

And did you reset/removed the calibration afterwards

Yes, i reset it

1 Like