Crash into bootloop

Hi folks,

my trusty Vero 4K (non +) has problems.
Some time after the march update I found the device stuck in a bootloop. Please wait → Logo → back to please wait → repeat.
I flashed the newest build via sd card, set everything up and enjoyed it for a while, just to find it stuck in the bootloop again today. I tried flashing the december build, which worked for a good hour, but eventually crashed into the bootloop again.
Im unable to provide logs, because I can only reach the system just once after another flash. If the log of a clean build would help to understand the problem I surely will flash it once more.
Could a dying power supply be the problem?

Thanks for any help.

Is Kodi crashing or the OS? If it’s just Kodi, you can still SSH in and get logs to determine what problem Kodi is having.

Sounds like a PSU issue.

@ActionA
I cant reach it via SSH. Doesnt surpise me, since the whole device seems to be restarting each cycle.

@grahamh
That would have been my next and my next best optimistic guess. I will order a new one and will reply.

If you can measure the voltage on the USB ports while booting that might confirm the diagnosis. But you’ll need an analogue voltmeter or oscilloscope.

After having it unplugged for a while, I was able to boot back into the system. I activated logging and report back after I get some logs after crashing.

Is it getting hot?

Right now: 67° C
I saw temperatures around 88° C today, after scraping the library again. This might be high, but not critical in my understanding.

Not critical.

Still running. Played around with updating the library, activating bluetooth and wifi a bit. Getting 83° C. Appears to be stable, but I smell a trap. Will switch to a new power supply, after it arrives. I keep observing.