Crashes each time I try to watch fanarts from the OSMC app

My OSMC is crashing each time I try to check in my movie library and it tries to load the fanarts.

I have just updated and upgraded everything. It didn’t crashed before I updated and upgraded.

Maybe something went wrong? Here is my log:

Also my TCP connection is not enabled, so it has a yellow color as connection in the OSMC app - I have tried to search how to enable TCP - but couldn’t find any help on Google? Could this be the problem?

What do you mean by OSMC app?


Hi Sam, my bad - Kodi Remote for iOS. Sorry :slight_smile:

Kodi iOS remote asks me if I want to enable tcp the first time I connect it to a vero it wasn’t connected to before. I click yes on the iPad and that’s that. No need to do anything on the vero

Check your Webserver user, it seems to be empty but not sure if that is related to the cleanup of the log up loader

Hi Fzinken,

The clean up of the log up loader? What do you mean by that? I am out of the office over the weekend, so I will first be able to modify the Webserver user on monday.

When you upload log files the script tries to hide your private information (usernames and passwords) so it might be that you have configured one but it is just not visible in what we see. But the entry looks strange so surely makes sense for you to crosscheck

Hi there,

I guess my webserver settings are fine. Have you checked the warnings I get in the bottom of the log?

Not really, but I was focusing on why your IOS Remote was not working, not the crash part.

Don’t you think it’s a OSMC issue? - Sending the fanart to the iOS App?

As I told - the problem first appears now after I have done apt update and apt dist-upgrade…

Do you have another power supply you could test it with? Are the drives plugged into it self powered?

The drives have their own power supply and I could test it with another PSU - but first on monday. :slight_smile:

I doubt if it’s a power supply issue. The log is showing that kodi.bin is using all the free memory, causing it to be killed by the system’s oom-killer.

What made me think it may be a power supply issue is that the only thing it shows as going on prior to that is converting a bunch of images with the CPU. I have personally seen my pi 3b+ work perfect until I told it to cache a bunch of art at which point it crashed (I didn’t look at my logs so I don’t know this is the same). My problem was a PSU right on the edge and OSMC never showed the power warning icon to help narrow down the cause.

Sorry for this post… Guess I found the solution by re-installing the Kodi Remote App.

I had made the mistake clicking “Please don’t show again” to the “Enable TCP” alert. This prevented me from activating TCP connection - now it is activated (because of re-installing the App) and now it works… Weird. Sorry.