Crashing sad face screen, fresh install

Hi, I’ve been using osmc on a pi 2 for awhile now and never had a problem, mostly used my pi for home media, now i’m looking into putting addons on the pi, I’ve ordered a pi 3 for my home media needs and such. I’ve kind of ran into this problem many many times, so i just not changed anything on it and stayed away from the issue, but now that I’m wanting to do more with the pi 2 and osmc I’m facing the problem alot more.

So on the the actual problem. It seems like when I change a skin or even navigate through some settings ( not everytime, but quite a bit, I can navigate through settings fine, but when I go to change somethings. ), I face this crash, sad face reboot. I’ve tried to google the issue but didn’t really understand what the other people were trying to say kinda. So I have no addons right now, this was a fresh install on the Pi2 and the lasest build of osmc to my knowledge ( via the osmc installer.)
This also happens sometimes on my Pi 3, latest build of osmc as well, but theres lots of stuff on that one so I’d like to start with the pi 2. :stuck_out_tongue: I’ve uploaded the log aswell.

EDIT: I also have an annoying mouse disappearing issue, usually happens on the crash reboot, or it will be a long line of wacky lines and colors.

  1. I suggest you get the default config.txt back
  2. Check your power supply, did you ever see rainbow color square in top right?
  3. Try a different SD Card

Thx for the reply,

As for the config.txt, is that as simple as rpi-update? Or is there more to it?

The power supply is currently 5.25v 2400MA, (it’s the power supply I got with the pi3) and the rainbow square, will that appear during the crash screen? if so what does that indicate?

The sd card is also one that came with the pi 3, it’s been wiped and formatted and fresh installed with osmc for the pi 2, I will see if I can find another sd card to try it with.

Rpi-update is not supported in OSMC. Our update process provides these updates as necessary.

As actiona wrote, rpi-update is not related to OSMC. I suggest you do a fresh install on another SD Card to check if that is working smoothly.

The rainbow color square would be shown either at the crash or before. It indicates that the powersupply is not providing enough power.

Thank you both for your replies, it seems like i didn’t read enough into the page to see that the rpi-update command belongs to a different OS, :stuck_out_tongue: so from here how do I go about getting the default config.txt back?

EDIT: keeping an eye out for the rainbow square, I replicated the crash and didn’t see it pop up at all.
EDIT2: I think I found a way back to defaults, and I’ve uploaded another log.
EDIT:3 Build seems to be much more stable now, I’ve been loading addons and constantly changing stuff so far no crashes, must have been the default config.txt, hmph, so simple, thanks for the help.

That log file still shows the same config.txt you had before

Hmm, I just tried to go into My OSMC and to pi config, then press default on the tabs there. I thought that would set it all back :stuck_out_tongue: is there another way to do get the default config.txt back?

Well you definitely changed config.txt but not for the good.
I suggest you ssh into your box and open /boot/config.txt in an editor sudo nano /boot/config.txt
Delete all content and add the following: