Crazy noise at boot time with Smsl q5 pro amp on Rpi3

I just bought the smsl q5 pro amp. It work well on my Rpi3 (auto detec on usb). But It emits crazy noise at boot time. This noise stop as soon as the osmc menu arrive.
Does anyone else use the same config?

Here a quick vid to show the problem:
Does anyone have any idea?

Yes, weird. Since there are reports of power supply issues with this amp on Amazon (sparks, electric shocks, even) I would suspect that’s at the heart of it. Maybe try another PS if you have one.

Thanks for the reply, I’ll check if I can find another PS to try this

Well… Can’t find any PS that fit into the amp…

If it happens with Raspbian as well, it’s not going to be simple to cure in OSMC.
If it happens when booting a connected laptop, sounds like a poorly designed amp.
Otherwise, I’m out of ideas.

Just for information, I’ve tried another PS: same behaviour

Hi @deck

i’m having troubles getting my smsl q5 pro working on my RPI3… what operating system did you install ?
I wanted to install an OS headlessly (no screen or keyboard) and so far the only one that properly enables ssh at first boot is raspBian… but then i didn’t manage to get my amp working, on usb.
Any lights ?

Sorry, i realize now OSMC is an OS… I’ll try with it then :slight_smile:

Raspbian is a better choice than osmc for a purely headless install.

If you try osmc can you tell me if you also have this noise during the boot sequence? On osmc the smsl q5 work without any specific configuration. I just have to select the audio output


i didn’t get any noise during boot, but i tried many installations of raspbian, ubuntu mate, osmc, runeaudio, and every time i get random problems or absence of a problem that occurred with the same install…

my goal is to have a media player with a web interface like runeaudio or kodi but on a “real” OS where i can setup and use any software, a web server for instance.
the main problem is that on raspBian i couldn’t get the smsl q5 pro working, and on ubuntu mate you cannot use kodi and i can’t find any other media player with a web interface (VLC “works” but you cannot browse your files from the web interface so it’s useless to me, and rhythmbox doesn’t play video files).
and now it’s getting worse : i reinstalled ubuntu mate and now i don’t see the smsl q5 available for audio output, though yesterday it worked on the exact same system…
so i guess i’m just going to try again with raspBian…

Have you tried volumio os?

Hi, yes I did. Volumio and runeAudio are more or less the same, but on Volumio sometimes the smsl q5 is not detected.
The main problem i have with both is network shared folders : I can’t mount my windows hosted music shared folder via the web interface, it says permission denied. If i mount it manually though it seems to work, but then it begins updating its database and all i can see in the mounted folder is the first subfolder, the rest never gets appended. The music folder is about 160 GB. This behaviour is the same in runeAUdio and Volumio.

edit : after about 20 hours it has appended some other subfolders, so i guess it’s only a matter of time. The problem is, if you unplug your drive or if anything unmounts it, you have to wait again 50+ hours to access all the music…

I think i’m gonna go back to ubuntu mate, and maybe make my own vlc interface…

Hello guys. Did anybody encounter this issue as well? I received my SMSL Q5 Pro amp using it with USB audio and I’ve got exactly the same problem. A very loud noise at boot. It didn’t happened when I was using a USB Dac to digital on my previous amp.

Do you have any idea what could be wrong?

I disabled “send noise” in audio settings but didn’t do anything. It looks like OSMC is sending a noise through usb and that my amp is “playing” it. Maybe it has to do with OSMC sending info to discover USB peripherals?

Thanks :wink:

Is there any reason you have to use the USB connection for the amp? Maybe the optical wouldn’t have the same issue.

Since the amp doesn’t support any of the lossless codecs, you shouldn’t lose any sound quality using the optical connection.

Hey, actually I plan to use the optical in of my amp to plug my tv (as it’s the only output possible). I then need to use the usb in coming from my rpi3