Crean Install and External Hard Drive

I tried to clean install osmc on my machine from usb.
plugged usb that installed osmc disk image, shut-downed machine, unplugged usb, turned on my machine again…
but I completely forgot another port still connected with my external HDD.
my machine formatted my external HDD, now my mac cannot recognize the ext HDD.
I know I’m idiot, but I guess I’m not the only one did this kind of mistake.
If there is someone who have the same experience, please give me an advice.
What can I do for my ext HDD?


If the the installer has formated the drive, that your data will be lost unfortunately. Sorry about that. But if it has been formated one of partitions will be fat32, which macos should be able to see. If you can’t see that perhaps the installer has formatted the correct usb, have tried unplugging the ext HDD and plugging it back in. If doesn’t work, what does disk utility report for the drive?

Also what device were you trying to set up osmc for, you didn’t say?

Thanks Tom.

On mac, diskutil list shows
/dev/disk3 (external, physical):
0: *1.0 TB disk3
GUI shows “Partition map is unsupported”
Also, Linux can’t recognize ext HDD.

The device I was trying to set up for osmc is Apple TV 1st gen(ext HDD was connected via Hub)

I guess atv didn’t have write permission for the ext hdd.
how was my data erased…(?)

Sorry this suggests to me the installer, has erased your data. Just Mac doesn’t support the new partition map, sorry looks like your data has gone. You should be able to delete the current partitions and start again with diskutil.

Regards Tom.

Don’t say sorry. not up-to-date but I have back-up.
Thanks for your reply and thanks for giving my atv second life.

Sorry, for reviving old topic, however, I can’t find an answer.

If I install OSMC on external disk, plug in additional external disk, and unplug first one (or maybe first one fails to load)… Will it automatically reformat other external disk and install osmc on it?

No reformating and installing only happens once. If the original disk can not be found OSMC will just stop booting.

I have a other/bad experience regarding that. My failure at most… However.

I have (had) two HDDs into raid1. I was trying to move root from sdcard to hdd… And did it in fstab. And f***ed up. After reboot, I lost 3TB of data, and of course, mdadm did a great job mirroring lost data to other disk. I didn’t see, what happened but I have a feeling that OSMC reinstalled itself on other drive.

OSMC won’t be able to reinstall itself without installation media.

The files to boot the installer are deleted after the initial install

OK. How come my HDD ended without partition and with new files? Is it “debian feature”?

Please bring more than a feeling when you come to suggest fault.

I doubt that Debian would have been the cause of your filesystem becoming empty.

What’s the output of cat ~/.bash_history | paste-log?

I’m not blaming anyone, I’m curious what happened.