Create a Hotspot with hostapd - RaLink RT5370

Hi,

I would create a AP on the latest OSMC Build “Linux osmc 3.18.9-3-osmc #1 PREEMPT Wed Mar 11 22:31:37 UTC 2015 armv6l GNU/Linux”

Hardware is: RaLink RT5370 on RPI B
Tried it with connmanctl but it won’t work. So I installed hostapd, ifupdown and udhcp, disabled wlan0 in connmannctl:

NetworkinterfaceBlacklist=wlan0

config Test says all good

sudo hostapd -dd /etc/hostapd/hostapd.conf

hostapd is up and running, but I can’t see any SSID, it should be broadcasting…

any idea what could be wrong?! I used this guide for setting up hostapd

regards

Not all wireless adaptors support host AP mode.

I have an Ralink RT5370 chipset adaptor (among others) and although I’d have to double check to be sure, I don’t think it supports AP mode and therefore won’t work with tethering in connman or with hostapd.

Some of my other adaptors do support host AP mode and do work with Tethering in connman in OSMC.

thank you for the reply, on Raspbian it is working in AP mode with hostapd.

regards

could that depend on the newest kernel, maybe that will help, but I don’t know how the do the correct implementation

regards

I’l get a driver error “failed to initalize driver” when testing the configuration with dd command…

Have you tried using the built in tethering feature in connman ?

guess what, that worked. don’t know why it hasn’t in the past, thank you!

regards

We’ve changed a few things recently with connman - one was that we changed the tethering option to persist across reboots. Previously you’d have to enable it manually every time you booted, now it will stay enabled until you disable it.

It also depends on whether the wireless driver is compiled with Host AP mode support. At the moment our rtl8192cu driver doesn’t seem to have working Host AP support, but most of the other drivers including rt5370 do.