Crystal HD support in Krypton?

I just updated OSMC to the latest version. Mostly it has been very pleasant until I played a 1080 movie when the motion was jerky. I guess that is what this thread is about.

I understand the sentiment to move on to fresh hardware but I am one of them CRT folk with a SCART S-Video input and I cannot find a Kodi box with that output.
I tried a modern 4 Core Android TV box going through an HMDI to S-Video/CVBS converter but the results are disappointing. Video motion is jerky even though navigation is rapid. Colour rendition has a bad hue and detail is lost.

The ATV1 box produces better results having been configured to output S-Video even though it navigates slowly.

Perhaps I need to go back to the last release until Krypton is ready.

Cheers for the great work Sam

You will have to do that! There will be no more updates, so Crystal HD support for Krypton will not come.

Oh, I see. Thanks for telling me.
From the thread, I assume the January build was the last one?
OSMC_TGT_appletv_20170129-HDD.img
I made a USB patch stick but it is not installing automatically.

Do you know if I have to use a different procedure to downgrade?

Yes

You would need to use the normal installation procedure. This will not be a downgrade but a clean reinstall of the January Image

I tried making a USB patch stick for a fresh install but it is not working.

So I assume I have to install via terminal. I am just trying to figure out the text.

I tried this:
sudo apt-get install OSMC_TGT_appletv_20170129-HDD.img
but it is wrong.

Any clues for the correct name of the file on the server?

As mentioned this is the wrong approach! This is not a patch or down/upgrade. Just follow the “normal” installation procedure using the installer on your PC/MAC to create a installation medium which you than need to boot from.

I do understand what you are saying. I have been trying to do a clean install of the January version using the “normal” procedure but it is still stuck on Krypton 17.4.

First using a Mac then a PC to make a USB “patchstick” or installer stick.

When I upgrading to Krypton I had problems with the install. Sad Face. I managed to fix it by following this thread: Problems when updating your ATV1 ? - READ HERE BEFORE POSTING!

Using terminal it sorted the HDD write permissions and upgraded to Krypton.

Another thread for downgrading for 17 to 16 on a RasPi Downgrade from Krypton Beta - #3 by fzinken
uses this command:
sudo apt-get update
sudo apt-get install rbp2-mediacenter-osmc=16.1.0-3

If I can substitute “rbp2-mediacenter-osmc=16.1.0-3” for the correct ATV version then I think it will work from terminal.

Sorry for stupid question but where I can download the latest OSMC image with kodi 16.x?

On Download - OSMC or using the OSMC installer.

I see, but all 2017 releases, where I can find information what kodi on what releases?

2017.01-1 or earlier is Jarvis

Thanks. Work like a charm!

New to OSMC, and before purchasing new media center hardware want to test drive a bit. Have a barely used circa 2010 ATV1 and purchased a CrystalHD card before reading enough to realize they are only supported until v16 of Kodi.

Downloaded and installed OSMC_TGT_appletv_20170129-HDD.img, then did an update using the GUI which failed, leaving the system in an unstable state, complete with a sad face.

Have now reinstalled. Should I disable updates? Not sure I like the idea of an out-of-date Debian install, therefore want to ask if there is a way to update the base OS without either going to v17 Kodi or encountering a glitch in the repository dependency matrix.

Suggestions?

No updates from OSMC anymore and as there is e.g. a relation between Kodi and libraries coming from Debian I would say you will not be able to stay up to date with it.

Understand. Will look into apt-pinning, or whatever that method is for freezing some packages but allowing others to be updated…

Yes.

Yeah, done already as a precaution. Thanks.

Hi,

I’m using the AppleTV with crystalHD and the january 2017 OSMC_TGT_appletv_20170129-HDD.img
In my case crystalHD acceleration is not working properly. Playback is jaggy and cpu load is reaching 100%

Do you have success with this old build? Is there any older build from 2016 available that offers smooth 1080p playback? If I understood right from this post, all 2017 releases except from January lacks crystalHD support…

Thanks

Hiya,

That version works for me.

Suggest you log into the AppleTV via ssh. Then type “dmesg” + Enter.

If CrystalHD is working this will be in the log when playback starts and ends:
[86932.740462] crystalhd 0000:02:00.0: Opening new user[0] handle
[86933.673662] start_capture: pause_th:6, resume_th:2
[87353.968359] crystalhd 0000:02:00.0: Closing user[0] handle via ioctl with mode 417a00

CrystalHD is very picky about what it will process. If I’m having issues w/a file, I throw it at Handbrake with the Fast 1080p setting and that works fine for me.

I’ve also had some weird issues with Kodi plug-ins. Never figured which one was/were the culprit/s, but they would make kodi pig out on RAM. The kernel would paginate, making everything sputter. If you are already ssh’d in, play something and type “top” + Enter. If you see kswapd topping the list and at same time everything sputtering or grinding to a halt this might be your problem. I changed the skin to Confluence, went into Plug-ins, and disabled EVERYTHING I could. Avoid disabling anything like helpers or you might disable the remote which means sifting trough XML to fix it or reinstalling.

I transcode anything before I load it to the AppleTV and the CrystalHD card chows through 1080p no problem.

Hope that helps.

Hi!

Sorry but only now I’m seeing you message.
Unfortunately I gave up on OSMC Jan 17 and I’m using Kodi Kinos, a Jarvis version based on Ubuntu 12.04. Works flawlessly for every 1080p movie I trow at it. It’s older than OSMC but works ok with CrystalHD.

Download it here

Original post here
https://forum.kodi.tv/showthread.php?tid=313407

I’m trying to build a more recent version for ATV1 based on debian buster 10.5 or Arch32. Sure your suggestions will help me debug if I have some problems,

Thanks