Currently any known issues with PAL and NTSC content?

Long time user, very happy with Vero 4K. I still have a bit of PAL and NTSC content that plays fine if I whitelist the relevant resolutions, however turns into a judderfest if I allow the Vero to upscale to 1080p. My TV is reporting good (i.e. matching) framerates in all instances.

I was hoping the October update would resolve this, but no significant change. Before I take any time up, is this a know issue please? Searching the forums suggest people have reported something similar, either with no clear resolution (for whatever reason), or it’s a simple adjust frame rate/sync to display settings issue.

Thank you.

Best regards,
Mark W.

It’s not a known issue, to my knowledge. Some debug logs should let us see what’s going on.

Apologies, I wasn’t following closely so had thought the October release had the new video stack for the Vero 4K (which was the only realson I was checking - I’ve had this problem for a long time).

Try removing the 25hz options from your whitelist.

No difference I’m afraid. In this example playback is 1080p50 (according to the TV) regardless of 1080p25 being whitelisted or not. Juddery and not watchable.

Have you tried with nothing in your whitelist?

Just tried that. Still the same. 1080p50 and bad judder.

Is the Dune S01E01 video causing the problem?

I see you have this changed from the default:

Accelerate MPEG2: HD and up ===> Default: Always

Try changing it back to Always.

I also noticed that you have cache settings in your advancedsettings.xml. You shouldn’t need those.

Changing accelerate MPEG2 to always does indeed seem to fix it. Thank you for the pointer. I’ve obviously gotten mixed up somewhere along the path as I had in the back of my mind software decoding of MPEG2 generally worked better.