Custom Background Color?


Settings > Interface > Skin > Configure Skin… > Background > “Untick Use Default OSMC Background” > Custom Background Color -> what does it do? I was excpeting that i can Change the Color of the blue Gradient in the Background. But it does nothing.

I have changed the blue backgroung gradient to a yellow gradient. But needed to edit the Textures.xbt.
But with every update i Need to edit the Textures.xbt…

Is there a more convenient way to Change the blue Gradient to a custom Color permanently?



There should be no need to change the textures.xbt. Here the color picker takes immediate effect and works as expected. Could you be so kind as to post a screenshot of your color picker settings after having configured it the way you want and before closing that window again?

Also, the settings of the color picker should normally survive an update.

It looks like I got to the bottom of this issue… I’d like you to test something for me, please. Do you know how to SSH into your OSMC device?



Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks to @Chillbo for fixes.



1 Like

Please mark the thread solved with the reply being the solution for you.