Customize Home Screen

Hello guys! sorry my english …

I installed OSMC on the Raspberry 3+ and would like to customize the home page.

I created 3 folders on the Synology NAS:

  • movie
  • TV series
  • cartoons

I created 3 sources, each for each folder.

then I create 3 shortcuts on the homepage, each for each source.

when I go to the hme page and click on a shortcut, I see all the sources doubled.

here the video.

where am i wrong ??


Well providing logs and also your skin configuration might be a better starting point.
Also not sure what you call "shortcuts. Did you added it files or sources in customize home screen?

It would seem that if you add a menu item and set the item to videos>sources>[movie source]>movies that does make it so the main menu item returns two identical submenus. Why it is doing this would be a question probably best answered by @Chillbo. The broken paths shown in your video I wouldn’t want to speculate on as I don’t know how you created those.

A solution that seems to work the way you want it to may be to go to Videos>playlists>new smart playlist and for movies you would set type>movies, name>[your preference], new rule>path - contains - [path to file share], ordered by sort title>OK

Click on the playlist to make sure it is populated correctly. Note that playlists will only display files that are scanned into your library.

Once you have a working playlist you can go back to the home menu configuration and set the item to videos>playlists>[name of the playlist you created]>display and then click on “enabled” and that should give you what your after.

This is a cooncidence indeed! I’ve just discovered that this specific issue has been mentioned over in the skinshortcuts script Kodi forum thread two days ago: script.skinshortcuts

The way @darwindesign has described as a workaround should do fine :+1:t2:

Thank you so much @darwindesign!!

First I created a sources for each directory (film, cartoon and TV series), then I created 3 smart playlist and finally I created 3 items for each playlist!

Now work!!

Thank thank!


Great, you could figure it out! Once there’s feedback from the original script dev, I’ll post whether this issue might get fixed some day.

Reply from the dev: Due to a lack of resources, this feature will most likely be removed from the script soon. So, the way @darwindesign has described will be the way to go in the future :+1:t2:

1 Like