Cypress release fix for onboard bluetooth audio stuttering

Hi guys

Been following this issue on github and just yesterday user posted a fix from cypress for the onboard bluetooth audio. See here Pi3 bluetooth audio stutters with Wifi enabled · Issue #1402 · raspberrypi/linux · GitHub.

Cypress have been looking into WiFi/BT interference and have come up with some new “NVRAM” file settings that they claim have “completely fixed the audio stuttering”. The same settings can be used on the 43430 (3B, ZeroW) and 43455 (3B+).

Locate your "NVRAM" text file - it's in /lib/firmware/brcm/brcmfmac<dev>-sdio.txt, where <dev> is 43430 or 43455 respectively. Make a backup copy somewhere safe to make it easier to undo the changes (or recover from an error).

Open the file in a text editor, scroll down to the bottom (purely for neatness - these settings could probably go anywhere) and append the following:

# Experimental Bluetooth coexistence parameters from Cypress
btc_mode=1
btc_params8=0x4e20
btc_params1=0x7530

Reboot.

As it was explained to me, these settings collectively allow Bluetooth more airtime by allow WiFi to sleep for longer and reducing the maximum time Bluetooth can be made to wait.

Please report back your findings, whether positive or negative, to help us decide whether to make these the new default values.

Users have been reporting success with this and no issues when transferring data using the onbaord wifi.

Unfortunately i’m trying to test this but can’t get bluetooth to connect. Getting bluez failed message. Has the onboard bluetooth been disabled on osmc. I’ve removed line dtoverlay=pi3-disable-bt from config.txt also.

Attempting to connect to 45:C6:59:42:A3:04
Failed to connect: org.bluez.Error.Failed

Thanks for any info

I’ve tested this locally for a day but haven’t found benefits yet.
I will continue to monitor this. But for now it needs more feedback before it can be included in OSMC.

Please post full output so we can see what you’ve tried to do.