D-link DWA-171 Dongle discovered as Mass Storage Device

Hi Guys, I’ve been trying to setup a WiFi dongle D-Link DWA-171 H/W Ver. C1, F/W Ver. 30.2 to a Raspberry Pi 3 running OSMC March 2020 2020.03-1. I checked the forums and tried to disable the built-in Wifi, but that didn’t help as the dongle is detected not as dongle, but as Mass storage device, I also followed few other threads outside OSMC forums where people bumped into the same issue with other Linux flavors. None of the suggestions worked as OSMC is not a full Debian and some packages are missing… see snippet from dmesg below:

[ 276.342124] usb 1-1.4: new high-speed USB device number 6 using dwc_otg

[ 276.472624] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=1a2b, bcdDevice= 2.00

[ 276.472644] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0

[ 276.472654] usb 1-1.4: Product: DISK [ 276.472665] usb 1-1.4: Manufacturer: D-Link Corporation

[ 276.473427] usb-storage 1-1.4:1.0: USB Mass Storage device detected

[ 276.474194] scsi host0: usb-storage 1-1.4:1.0 [ 277.522442] Default I/O scheduler not found. Using noop.

[ 277.525101] scsi 0:0:0:0: Direct-Access Realtek Driver Storage 1.00 PQ: 0 ANSI: 0 CCS

[ 277.526102] sd 0:0:0:0: Attached scsi generic sg0 type 0 [

277.526279] sd 0:0:0:0: [sda] 16000 512-byte logical blocks: (8.19 MB/7.81 MiB)

[ 277.526553] Default I/O scheduler not found. Using noop.

[ 277.528991] sd 0:0:0:0: [sda] Write Protect is on

[ 277.529011] sd 0:0:0:0: [sda] Mode Sense: 03 00 80 00

[ 277.531608] sd 0:0:0:0: [sda] No Caching mode page found

[ 277.531623] sd 0:0:0:0: [sda] Assuming drive cache: write through

[ 277.552969] sda:

[ 277.559748] sd 0:0:0:0: [sda] Attached SCSI removable disk

Is there any way around that or I just bought myself an unusable dongle?

If so, is there any reliable way to enable 5Ghz on RP3 using a dongle and running OSMC. Libreelec and Openelec has the same issue as OSMC… The only one I got it working is Rasbian, but don’t want to use Raspbian for only running Kodi on it? Maybe a different dongle that somebody tried? There is no official dongle on sale any more…

Thanks Yordan

I think you’ll need to install the usb-modeswitch package. The command to run is also usb-modeswitch. Configuration can be a bit tricky, so I suggest you search for a few “How Tos”.

Already tried that, when I use usb-modeswitch it does changes to the correct device, after e reboot it is again discovered as mass storage device, anyway usb-modeswtch only changes the type of the device, the drivers for it are still missing… tried all the how tos i could find, but every led to a dead end either OSMC would error or miss that functionality… thanks anyway.

It would have been useful – and saved my time – if you’d mentioned that you’d already tried usb-modeswitch. If the device reverts to mass-storage after reboot, why don’t you run if as part of the startup, eg from rc.local?

As for the drivers, you’d need to provide a log after running usb-modeswitch. If they’re Realtek, you might be out of luck until Sam reinstates them.

Sorry, missed that part… wasn’t on purpose to waste anybody’s time. The chipset is most definitely Realtek (probably one of the reasons OSMC has stopped their support… the drivers haven’t been supported in quite a long time). With that said I did found one thread where they used dkms build essentials, but that fails in the last step when trying to complete the driver with missing headers which I wasn’t able to find a solution for…


Sam did advise to open a topic in the forum and said “personally keep an eye out for your post”.

If the Realtek drivers have been removed, have you been able use any other USB WiFi dongle with OSMC that supports 5Ghz?

DKMS doesn’t currently work on OSMC for a number of reasons, and manually building the driver can be problematic as a result of ongoing issues with the kernel-headers package.

I can’t answer your question about 5 GHz dongles, not having one myself. The OSMC store used to have one but it looks like it’s no longer available.

One possible piece of good news is that Sam has said he’ll be reinstating some of the Realtek drivers on the Pi kernel that he’d previously withdrawn. Whether that will help with your device I can’t say, and neither do I know when the drivers will reappear.

Thanks for all the useful information. For reasons I can use LAN with the pi, and the router is at least 10m away with a wall or two between. I am starting to consider a WiFi repeater and short LAN cable. My problem comes when streaming 1080p and the wifi is so slow that it is unusable…
Nothing else I can do, but wait and see if the drivers will be added and that would make a difference.

Generally, WiFi repeaters perform poorly. You might have more success with powerline adapters or, ideally, find a way to route some cable between the devices.