Dark shadows with OSMC’s November Update


I updated my OSMC, but experienced the shadows are too dark with HDR content. All scenes in a dim environment or at night are much darker compared to my previous version. The video lacks some punch. I tried several 4K HDR movies.

I didn’t changed anything on my LG C8 OLED television. Other content from other sources (like YouTube) is perfectly fine.

I tried a warm and cold reboot without any change. I suspect some setting got changed after the update, but cannot find it. I hope someone can point me to the right setting.

Also, is it possible to rewind to an older version of OSMC? (In case it doesn’t work).

We didn’t change anything with HDR in November. We just pass HDR straight through to HDR-capable displays. Always have.

To go back to the August version you would have to reinstall.

I didn’t update for a year I think. Before the update the device showed version: OSMC November 2020 2020.11.1

I used the command line (hotfix: ucawobahij) to forse the update. Maybe that caused some change?

Ok, then the main change we made (in August) is we’ve disabled contrast and brightness for HDR video when playing to an HDR display. So if you had those set for any HDR videos they will no longer apply. This is so that users can use those settings for HDR-SDR conversion without affecting HDR displays.

You should be able to go back to November 2020 but you will need to re-enter all your settings.

Thank you for the reply.

No, I didn’t used that option. I never changed brightness or contrast for a movie.

The problem is that the darker parts of a scene appears darker. The mid- and highlight are still good. Are there any other options in the settings I could try? I already browsed anything in the advanced menu, but there are not many options available.

Going back to an older version is an option when the problem remains. Where can I download these with some instructions?

I just thought, the other change between November 2020 and now is we are passing through all the metadata so in theory your TV is getting better information about the stream than it did before. If you are finding all HDR video has dark shadows now, maybe you should look at adjusting the brightness on your TV. Usually it’s a separate setting for HDR and SDR.

We would rather users didn’t go back to previous versions as we like to keep moving forward but if you really must, see here.

Thank you, something to look into.

Am I correct to assume that the Vero 4K+ doesn’t change the appearance of a movie per se, but only passes it through from the SSD to the display?

If so, then I don’t have to focus on the Vero and maybe something else coincidentally changed in my setup.

That’s the aim, but the metadata (mastering display characteristics, stream maximum luminances) has to be broken out and re-packaged for HDMI. That wasn’t working fully until August 2021 - we were passing through some default values. It is working properly now. So your TV would have seen something a bit different (but potentially incorrect) last year.

1 Like

I tested the setup with HDR10 black level test files and it seems to work properly. I noticed a change, maybe in color saturation or something else, but, … as you stated, maybe because of the passing through of all meta data. I prefer a true picture quality.

I’m glad the black level is ok and it seems I only have to re-calibrate my brain. :wink:

Thank you for the support.