Database unavailable from new Vero 4k+

I just plugged in my new Vero 4k+ and copied over the same advancedsettings.xml and sources.xml that I use on my Raspberry Pi 3 and Odroid C2 machines in hope that it would work as well on the Vero. But even though my sources are mounted correctly and I can browse them, I cannot connect to my database to fetch my library.

The following is just an snippet from the logs:

17:24:49.153 T:4054840064 ERROR: Unable to open database: MyMusic60 [2003](Can’t connect to MySQL server on ‘’ (101 “Network is unreachable”))
17:24:49.153 T:4054840064 ERROR: Unable to create new database
17:24:49.154 T:4054840064 ERROR: Unable to open database: MyVideos107 [2003](Can’t connect to MySQL server on ‘’ (101 “Network is unreachable”))

There are more lines here where it tried various MyMusicXX and MyVideosXX databases with the same result.

I also have a path substition for Thumbnails which also do not work

17:24:47.756 T:4075147856 ERROR: Create - Error creating /home/osmc/.kodi/userdata/Thumbnails
17:24:47.756 T:4075147856 ERROR: Create - Error creating special://masterprofile/Thumbnails

There are many more lines here as well for each subdirectory in thumbnails.

It works on my other devices, so why does it not work on my vero?

Full logs would give us more information, but from that snippet it looks like you have a network problem. Can you ping Does the MySQL server have any IP based restrictions?

Yes, I can ping. I can also reach my shares via nfs on the same server. I’ll add the full logs, will just clean up from sensitive information first.

If you can ping then I’d suggest looking closer at the MySQL server.

What happens if you:

telnet 3306

You should see something like this:

Connected to yeti.local.
Escape character is '^]'.
5.5.5-10.1.37-MariaDB-0+deb9u1�Ntz*`&7?�V``@_>Us`iormysql_native_passwordConnection closed by foreign host.

Yep, I do get that type of response trying that.

Log is here: - Share Text & Images the Easy Way

Let me know if there is anything more you need.

Then again I’d suggest looking closer at the MySQL server. It’s responding. My guess is the login you are using is IP specific.

Its odd, because it works from other devices on the network. Also odd because the thumbnails path substitution doesn’t work. I’m guessing its something with the NFS permissions there which I will have to dig down a bit to find whats going on.

The only other thought I have is possibly a duplicate IP address. You didn’t supply full debug logs so it’s hard to guess any more.

Pasted the full logs just before your last message. Must have missed it. :slight_smile:

That is not a full debug log.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Gotcha, thanks. Will do that.

Here we go:

Nothing jumps out at me in the logs. Could you try installing the mysql client (unless it’s already installed) and manually connect to the MySQL server?

sudo apt install mysql-client
mysql -h -u kodi -p

That worked fine. I could log in, use the database and see the data from that database.

Used use MyVideos116 and SELECT * FROM movie;

Also no errors in the mysql logs on the server.

Did a packet capture now on the server of the mysql server, and noticed no traffic during a reboot (on tcp port 3306). Seems like network is not enabled when its trying to access mysql server?

EDIT: Seems like I can’t make new messages, so I’ll edit this one: That (Wait for network) did the trick! I recall I had a similar problem a while back with libreelec. All good now, thanks!


Good to know that fixed it. Did it also fix your path substitution problem?

Yep, fixed all issues.

In MyOSMC do you have ‘Wait for network’ selected?

1 Like

Good to know that fixed it. Did it also fix your path substitution problem?