Date and seasons mixed up in TV-shows library


I’m using a Vero 4k + and my TV shows are on a Synology server DS214+.
When I add TV shows to the library, the year of release is mixed up with the number of seasons, eg Fawlty Towers, first release in 1975, 2 seasons becomes 19752 seasons in the library. All TV-shows in the library behave like that.
I don’t know if this came up from the beginning or if it is a recent issue.
I’m using the default osmc-skin on osmc 2021.12-1.
How can I fix this?

Thank you.

This might be one for @Chillbo to look at.

I assume that this doesn’t occur on another skin?

Thank you for your support.
I have only tried the “normal” Estuary skin so far, but it does not display details like the osmc skin does.
I don’t know which of the additional skins display all the details in the same way that the osmc skin does.
If someone knows of one, I’ll try it, but I’d rather not download all of them.

Thank you for pointing me to this bug… I’ve already fixed it in code and it will be available as soon as we can push it to users :slightly_smiling_face:


There should be an update released with this fix in a few days.