Dead Vero4k?

Found that My Vero4k was not outputting anything. Unplugged and plugged back in. Red light flickers dimly and inconsistently.

I assume that the box is dead, but it cost me nothing to ask on the forum first just in case I have overlooked something.

I’d suggest trying another power supply, as well as posting a photo of the one you’re currently using so we can verify it’s the correct one.



Will my 4k+ power supply work on the 4k as a test?

It is the supply that came with the unit, and it has worked fine for months.

Yes – it will. They’re interchangeable.


Yeah, same situation. flickering dim red light, intermittent flicker to dark.

Assuming you have two setups, try move the malfunctioning Vero to the working setup (PSU; HDMI; TV) etc.

I have moved the V4K to my V4K+ spot and plugged everything in. The light still doesn’t stay on in the front (and flickers) but I get HDMI output for a while, until the screen eventually goes black. I never make it to the OSMC start screen.


Alright, after 10 minutes (give or take) it finally showed back up. So, that’s good. Took it back upstairs and the same thing happened again. Looks like I need a new PSU.

Edit: I don’t see a PSU in the store. Sam, any way to get just the power supply?

Appreciate the help!

Any connected peripherals to the Vero (i.e. HDD)?
Otherwise the device is malfunctioning and I’d suggest starting a request at