December 2017 Update Resulted in Sad Face Loop

I ran the update, and turned off the TV as it was running.
When I turned the TV on quite some time later, there was no HDMI signal coming from OSMC.
I rebooted OSMC and find it in SFL.

Can still SSH in and get logs

Any thoughts?



BTW When I SSH in and run sudo apt-get update then I get

Hit stretch InRelease                       
Hit jessie InRelease                            
Hit stretch/main armhf Packages             
Hit jessie/main armhf Packages                  
Hit stretch/contrib armhf Packages          
Hit stretch/non-free armhf Packages         
Hit stretch InRelease                                       
Ign jessie/main Translation-en_NZ               
Ign jessie/main Translation-en                  
Get:1 stretch/main armhf Packages/DiffIndex [2,023 B]       
Ign stretch/main Translation-en_NZ                          
Ign stretch/main Translation-en            
Ign stretch/contrib Translation-en_NZ       
Ign stretch/contrib Translation-en          
Ign stretch/main Translation-en_NZ          
Ign stretch/main Translation-en             
Ign stretch/non-free Translation-en_NZ      
Ign stretch/non-free Translation-en         
Fetched 2,023 B in 45s (44 B/s)                                                
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

When I run sudo dpkg --configure -a I get the following errors

dpkg: dependency problems prevent configuration of rbp1-mediacenter-osmc:
 rbp1-mediacenter-osmc depends on libpcrecpp0v5; however:
  Package libpcrecpp0v5 is not installed.

dpkg: error processing package rbp1-mediacenter-osmc (--configure):
 dependency problems - leaving unconfigured
Setting up hdparm (9.51+ds-1) ...
Removing obsolete conffile /etc/d

Buuuut… running sudo apt-get update again, now results in no errors…

Then running sudo apt-get dist-upgrade I get the following errors

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libboost-filesystem1.55-dev : Depends: libboost1.55-dev (= 1.55.0+dfsg-3) but it is not installable
 libboost-system1.55-dev : Depends: libboost1.55-dev (= 1.55.0+dfsg-3) but it is not installable
 rbp1-mediacenter-osmc : Depends: libpcrecpp0v5 but it is not installed
E: Unmet dependencies. Try using -f.

And sudo apt-get -f install?
But you might be in a half upgraded state which could be a an issue

So I ran apt-get -f install and then retried

sudo apt-get dist-upgrade and it appears to be processing OK atm…

Yeah so believe it or not, that recovered it for me!

After the above I then reran

sudo apt-get update
sudo apt-get dist-upgrade

And got no errors, so did a sudo systemctl restart mediacenter and we appear all good! :slight_smile: