December update: broken wifi, samba and torrents

Hello OSMC folks.
Immediately with the December update, the following observed on my Raspberry Pi 3:

  1. Wifi (wlan0) won’t connect automatically anymore, requiring manual intervention on every reboot.
  2. nmbd and smbd fail to start (" reinit_after_fork() failed, error code 2") which in turn does not allow samba to run.
  3. Torrenter add-on cannot work anymore: search runs OK, but looks like it cannot parse torrent file content anymore, so no file listing displayed.
    .
    https://paste.osmc.tv/rocadewuvi

P.S. Update rollback feature would be really appreciated… Thank you guys anyway for the outstanding system!

OK, Samba issue resolved by:

  1. as @fzinken recommended in the thread: Samba is not working - #25 by Fye , replace the smb.conf with new distribution version after update.
  2. partially restore the config, but cross-check with samba new manuals as options like “security = share” cause samba to crash
  3. (optional) bind only to specific interfaces to avoid mentioned wifi problem (1).
  4. re-add and re-enable cifs users with smbpasswd
  5. add “ntlm auth = yes” to smb.conf to keep old behavior

The rest (1) and (3) still broken, unfortunately.
apt-get update and dist-upgrade double-checked, nothing to update, no issue.

Any idea on what’s wrong with Wifi and (python) parsing since December update, please?

You’ll have to ask the developer regarding point (3).

As things stand, on your system you are successfully connecting to wired (eth0), so connman will not try to connect to wlan0 automatically. (The file /etc/connman.conf contains the line PreferredTechnologies=ethernet,wifi to prefer ethernet over wifi.) There is a description of how it works at Documentation | 01.org.

You can still try a few things:

In connmanctl make sure that autoconnect is true for the wifi interface. (Type help in connmanctl for more information.)

If that doesn’t work, a simple shell script running the connmanctl connect wifi_xxxxxx_managed_psk command might also work.

Edit: Please also look at this post: Network Config: two networks - #7 by JimKnopf

Wow. Thank you @dillthedog looks like exactly that issue. Never thought good old /etc/network/interfaces to be replaced with this strange stuff. Still not clear why did it work before, anyway:
located a more detailed reference and added to the /etc/connman.conf:

AlwaysConnectedTechnologies=ethernet,wifi
#AlwaysConnectedTechnologies = -------------> List of technologies with AutoConnect = true which are always connected regardless of PreferredTechnologies setting

Thanks a lot!

Ничего!

Finally, Torrenter issue resolved, too: looks like the system update removes libtorrent.