December Update RPI2

December Update getting stuck…Been waiting for 10 minutes, nothing happens.

Wait a bit longer, you may have a slow SD card, and the kernel image is a bit package

Thanks! Just had to wait longer like you said =)

I tried updating earlier today but ended up pulling the power cable, but now I let it stay on untill it worked. Took about 15 minutes.

Don’t pull the plug on it, try logging in with SSH and running ‘top’ to see if there is activity.

Just a thought: if possible, it might be helpful to have a flashing cursor or similar on the update screen shown above to indicate that the system is still working. Sometimes it does sit at one task for a while, some movement on screen might help reassure non-tech users that the system is not hung or frozen. Not a big deal either way.


Nice idea, except a flashing cursor on a Linux console is done at a very low level in the kernel - nothing short of a complete hard system freeze would stop it flashing so the update process hanging or getting stuck in a loop would not stop the cursor from flashing.

Monitoring the update procedure for continued “progress” is very non-trivial - if we knew all the ways that the update process could get stuck we would fix them rather than just try to detect them. :smile:

We’ll keep it in mind though and see if any ideas come up.

No problem, thanks for your thoughts. I suspected as much.