December update, transmission-daemon 2.94


#1

After upgrading osmc to latest update, I expected that transmission-daemon would at version 2.94, but that is not the case.

user@rpi3:~/torrents/complete$ transmission-daemon --version
transmission-daemon 2.92 (14714)

On page https://osmc.tv/2019/01/osmcs-december-update-is-here-2/ in section Miscellaneous, it is stated:

  • Updated Transmission torrent client to 2.94

I have installed transmission with apt-get install transmission-daemon.

Am I doing something wrong?


#2

Hi,

You need to install transmisson for the the MyOsmc App Store.

I suggest removing the currently installed version and install from the App store, to get 2.94.

Thanks Tom.


#3

I have tried to install it before I have purged transmission-daemon installed with apt-get, and I have got an error:

OSMC UPDATE ERROR
ERROR INSTALLING: ARMV7-TRANSMISSION-APP-OSMC (2.9.4-1)
PLEASE REPORT THIS ON THE OSMC FORUM

SOME PACKAGES WERE NOT INSTALLED/REMOVED
DETAILS HAVE BEEN WRITTEN TO THE KODI LOG

Now I have purged transmission-daemon (apt-get purge) and tried to install it again from OSMC app store but the error remains.

My RPI is of the latest version.

Can you please help?


#4

We would need to see logs.
You likely still have some Transmission packages on your system


#5

I have removed it with sudo apt-get purge transmission-daemon

I believe, that is sufficient.
How tho check it?


#6

dpkg -l| grep transmission


#7

Hi,

Typo from @sam_nazarko in the last post, it should be:

dpkg -l | grep transmission

Thanks Tom.


#8

user@rpi3:~/.kodi/temp$ dpkg -l| grep transmission
ii transmission-common 2.92-2+deb9u1 all lightweight BitTorrent client (common files)


#9

apt-get remove transmission-common?


#10

There is nothing in kodi.log


#11

sudo apt autoremove helped.

Thanks guys.