Default audio delay for 4k-HDR only

#1

My Vero 4k is connected to my Denon X4400H AVR which in turn is connected to my LG OLED C7.

For 1080p movies the video and audio are perfectly in sync without having to adjust it in the AVR.
However, for 4k HDR movies there seems to be a delay in the video signal processing on the AVR and I have to add a 75ms delay to the audio in Kodi for the movie. This happens for all 4k HDR movies.
I can’t use the AudioSync feature on my AVR as this would cause the 1080p movies to be out of sync. I’ve tried playing around with the “Auto” feature on the TV and AVR but it seems to be making things worse.

The thing is, I had a Marantz NR1608 sometime ago and no audio issues with 4k HDR content. It had no GUI-Overlay feature for 4k HDR, the Denon does and I think that’s what’s internally causing the additional delay. I wrote Denon about it, they told me to use the Game Mode on my TV (lol).

It would be nice if we could somehow add a default delay for 4k HDR files, so I don’t have to adjust it for every movie every time I watch one. My girlfriend is already overwhelmed with changing the input source on the TV to the Vero, I can’t explain to her how to adjust the audio delay every time and do that only for 4k HDR files.

0 Likes

#2

First, 75ms delay really isn’t that much…it’s two frames of video. Usually, audio needs to be off by nearly 200ms before it becomes noticeable, so you might want to experiment a bit to see if more delay is actually needed.

But, if you are using MySQL, the following will set the audio delay for all 4K movies:

UPDATE settings
SET AudioDelay = -0.075
WHERE settings.idFile IN (SELECT streamdetails.idFile FROM streamdetails WHERE streamdetails.iVideoWidth > 1920)

Kodi doesn’t keep info on whether a 4K movie is HDR or not, so if the problem is only with movies with HDR, then there is no way to do it in one shot.

0 Likes

#3

The delay might be more but setting it to 75ms will make it seem in sync. I’ve tried 125 and it was alright too. So it’s possible there’s actually more delay but reducing it by 75ms puts it back into the “not noticable” range.

Thanks for the SQL script. I might have to add a cronjob in the Vero or something but I’d prefer if it was just a setting or something. You can already set a default delay in Kodi, but it’ll apply to all videos unfortunately.

0 Likes

#4

FWIW, works in Kodi’s db as well.

1 Like

#5

I wasn’t sure, because of the nested SELECT.

0 Likes

#6

I just realized the SQL would only work for files that have been played at least once or are scanned into my library :neutral_face:

0 Likes

#7

If they are not scanned, they are not in the library… Which is correct. :}

0 Likes

#8

I think they meant the video mode of your AVR’s output settings which can be automatic, movie and game, see http://manuals.denon.com/AVRX4400H/EU/EN/GFNFSYmlxuhedk.php

1 Like

#9

I haven’t seen that before, I’ve only tried the Game mode under “Picture Mode”. I’ll try to see if this fixes my issue and will report back, thanks! From a quick Google search I couldn’t find what the Game Output Mode actually changes on the AVR as I can still use overlays, picture modes, conversion etc. with it on so I’m curious about what drawbacks it must bring.

0 Likes