Default audio device for BubbleUPNP


I am using a RPi 2 (running OSMC / Krypton) with a USB DAC (Sound Blaster X-Fi) connected.

The DAC is configured with ALSA and working fine, I primarily use it with spotify-web.

When streaming to Kodi with BubbleUPNP audio goes out via the standard device configured in Kodi (HDMI in my case).

I would like to modify my configuration so that audio from BubbleUPNP (or alternatively any music playback) is always sent to my USB DAC, without changing the default device in Kodi.

Can anyone point me to a solution / way to achieve this?

Thanks :slight_smile:

You need to change the audio output to the DAC in Kodi for audio to be routed there. I’m not sure why you wouldn’t want to set that.

My issue is that a) I am unable to get passthrough working properly with the DAC and more importantly b) the DAC is connected to my AVR via toslink and therefore does not support HD audio formats or multichannel PCM

So I am looking for a comfortable solution to use the DAC for music and the standard HDMI interface for everything else.

I found a workaround in the meantime though:
Audio Profiles Kodi Add-on
For anyone interested, it allows to define separate settings for Video / GUI / Music

Thanks for pointing that out, works like a charm the only issue I have in the moment that Music Addon is not detected as music. But having the button configured to change profiles works.

Glad I could help! For me, (when streaming to the integrated music player with BubbleUPNP) automatic switching works ok.

I am still looking for a more elegant solution though… But it would require Kodi to be able to use multiple audio devices at the same time I guess - any chance?

Otherwise doing it on OS level might be an alternative (as with spotify-connect-web) :thinking: