Degraded picture quality after December 23 update

I already reported this in the December update thread but wanted to create a new topic as I wasn’t able to solve this yet.
After updating my 4k to the December 23 update and watching several 1080p x264 videos from various sources on my sony projector I was wondering why the picture quality now is so bad. The 4k is set to hardware acceleration for every video format.
I often saw individual areas in the image slowly moving around or shaking, just as if it were encoded with a very low bitrate. Also there was streaking like some kind of motion blur and noise in darker areas. It’s hard to describe…

With the previous updates I never experienced this and I did every available update.
I tried to switch on/off several options (like HDR or HDMI settings), but nothing resolves this.
When disabling hardware acceleration everything looks clean, but the image stutters alot.

I exported a little sample clip that shows the problems:
Dropbox - Clip.mp4 - Simplify your life
The first scene with the black guy shows a lot of streaking and noise on the right side of his face.
In the second scene with the white guy have a look at the glasses, they do not move the same as the head does.
The clip looks fine with every player on the PC I tried and except of the stuttering also with the 4k without hardware acceleration.

Maybe you could have a look.
Thanks, Marc


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Can you try this DNR filter - #16 by grahamh

@grahamh Yes, this fixes it. I can work with that until the update is out.