"Delay in Playback on certain videos"

I have the latest a Vero 4K+ running the latest version of OSMC.

The Vero is connected to a Samsung soundbar and the soundbar is connected to a TCL TV.

The problem:
On some mostly 720p videos there is a delay of about 4 seconds and the setting “Delay in Playback on refresh rate change” does not work whether I set it to 1 second or 20. On the Vero audio starts after like 0.5 seconds of clicking on play while the screen is still black as it is switching refresh rates. Passthrough is ON and Adjust Refresh rate switching is ON.

This doesn’t happen with all videos, but only some. I tested it on my laptop and on my phone and the issue doesn’t occur. I play my videos over wifi and using upnp from my laptop. As far as I know this never happened with high bitrate HDR 4k movies, 1080p movies.

Also weirdly skipping back to the beginning of the video doesn’t work, it simply happens again.

Below is a video of where it happens.

Here’s the the link to a log:

I hope someone knows what does could be.

It could just be a delay in cueing up caused by both using wifi and UPnP, both of which are slower than alternatives. I assume if you took that same file and put it on some storage media that was directly attached to the Vero it would play as expected. Your also running a rather heavy skin which might also impact it to some extent.


I was thinking that as well, but it doesn’t make sense since it doesn’t happen with videos that require more resources like x265 HDR 4k movies with way higer bitrates. This problem I described also happens on a few 720p original Star Trek episodes.

I’ve tried playing the video from both a USB stick and a external drive directly connected to the Vero and it still happens. I myself think that it has to do with something about the way the video has been encoded and that’s why it happens to only some videos.

Maybe try disabling the allowing double refresh rates and/or your whitelist and see what that gets you.

You might also try disabling the unpause jumpback add-on and see if that makes a difference. I don’t see anything that would indicate an issue with it but it has been known to sometimes cause errant behavior so it may be worth a try.

1 Like

I’ve tried, but it didn’t make a difference.

I still believe it probably has to do with the video itself or else it would have happen with either all or most videos. I’ve deleted and replaced it and I will do the same to any videos I come across with this problem.

Thanks for your suggestions @darwindesign