Delay start Transmission in OSMC / retrasar inicio Transmission en OSMC

Translate with google translate.

Good morning.

I installed Transmission on OSMC, not from the apps store. But with APT.

Apt-get install transmission-daemon

The problem I have is that I have indicated that I download to an external (powered) HDD. And it starts the service before the mapping of the HDD, so it gives me error.

Does anyone know how to delay the start of the transmission-daemon service?


Buenos dias.

He instalado Transmission en OSMC , no desde la tienda de apps. sino con APT.

apt-get install transmission-daemon

El problema que tengo es que he indicado que descargue en un HDD externo (alimentado). y arranca antes el servicio que el mapeo del HDD, por lo que me da error.

¿alguien sabe como retrasar el inicio del servicio transmission-daemon?


The Transmission package in Debian’s repository still uses /etc/init.d which makes this harder to do. Is there a reason you did not pick the package from the OSMC repository?


I’ve been testing for a while, the files were getting me down and I did not have permissions on them, to move them to other HDDs.

I have not tried it since.

hace tiempo haciendo pruebas, los archivos me los bajaba y no tenia permisos sobre ellos, para moverlos a otros HDD.

no he probado desde entonces.

It would be much easier to use the OSMC package and resolve any problems you may have with it than to try and get a different version working.

I suggest you run:

sudo apt-get purge transmission-daemon and then install from the MyOSMC app store and post back here with details of any problem you may have with full debug logs.


Fact. After installing the version of the APP Store it works OK. In case someone gives with this post with this problem indicate that.

1 Install from the OSCE Store App.
2 In services disable the service.
3 the configuration file is in “/home/osmc/.config/transmission-daemon/settings.json”

Changing the line that indicates

“Umask”: 18,
“Umask”: 2,

For files to be created with permissions that let them move, rename, delete, etc.


Buenas noches.

Hecho. Tras instalar la versión de la APP Store funciona OK. por si alguien da con este post con este problema indicar que.

1 Instalar desde APP Store de OSMC.
2 En servicios desactivar el servicio.
3 el archivo de configuración esta en “/home/osmc/.config/transmission-daemon/settings.json”

cambiando la linea que indica

“umask”: 18,
“umask”: 2,

Para que los archivos se creen con permisos que dejen mover, renombrar, borrar, etc.