Delay Transmission start on boot

I just installed Transmission, and I’m having an issue with the autostart. The problem is the transmission service starts, before the system mounts my HDD. This is a problem, because the Transmission can’t access the files.

I saw few people having the same problem, and they fixed adding a delay to the /etc/init.d/transmission-daemon file. I tried this too, but it did not work. I even deleted the file, and the transmission still started on boot. I’m guessing the script which starts the daemon on boot is located somewhere else.

If anyone knows know how to fix this, please help me!

If you had installed the version of transmission from the OSMC App Store you’ll find it already has a 10 second startup delay for this reason. I’d recommend you uninstall the Debian version and install the OSMC version.

I removed the debian version, with apt-get, then tried to install the transmission from the app store, but it failed.

Is there any log what i could show?

Make sure you purge the old package not just remove it. Apt log is at /var/log/apt/term.log

1 Like

I used both remove and purge.
Here are the logs:
Log started: 2016-06-25 20:19:23 (Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40$ Preparing to unpack .../armv7-transmission-app-osmc_2.8.4-11_armhf.deb ... Unpacking armv7-transmission-app-osmc (2.8.4-11) ... dpkg: error processing archive /var/cache/apt/archives/armv7-transmission-app-osmc_2.8.4-11_armhf.deb (--unpack): trying to overwrite '/usr/share/transmission/web/images/favicon.png', which is also in package transmission-common 2.84-0.2 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/armv7-transmission-app-osmc_2.8.4-11_armhf.deb Log ended: 2016-06-25 20:19:24

Found this thread, and managed to fix the installation.

How to close this thread?

No need to close the thread. Other people with the same problem may want to comment later.