Delete Folder - Permission Denied

Hi guys
I wish to delete an addon-data folder but I get permission denied…error code 3 and request code 15
Using WinSCP - also tried filezilla to delete but failed
I tried from File manager in osmc but failed also.
The problem folder is .acestream from program.plexus

Setup - R pi 2 with latest updated osmc

Two things come to mind here, either permissions or a process has a file in the directory open.

I doubt that it’s permissions, since everything under .kodi should be owned by osmc, but it’s worth checking.

If the file is being held open, you could try ssh in, and do

sudo service mediacenter stop

then remove the file and restart kodi

sudo service mediacenter start

If that doesn’t do it, just shut down the Pi, put the SD card in a PC and remove the directory.

1 Like

sudo service mediacenter stop… didn’t work
next…will try removing the sd card and delete from pc
thanks…will let you know how it turns out

why dont u ssh into osmc then just sudo rm -r ?
or ssh with user osmc then use su . now u have root access do anything u want

Because it should be
sudo systemctl stop mediacenter

tried this…command not found

still get error code when trying to delete

So you must be typing it wrong. There is no way that that command is not found or your system would not be booting.

sudo systemctl stop mediacenter

Use copy and paste. :wink:

it was the previous user’s [hestiny] post which did not work…
sudo systemctl stop mediacenter works - it did stop kodi but still wasn’t able to delete folder

Exactly what folder are you trying to delete? At least what is it’s base location?

should mention that I have the PI setup with sd card and usb
can’t access usb when I plugged it to my pc

…there’s an ACEstream folder inside program.plexus that does not get deleted

i didnt write the exact code there .
i assume that u can ssh into osmc then type following

sudo rm -rf /home/osmc/.kodi/userdata/addon_data/program.plexus

note that this will delete the whole program.plexus folder

1 Like

wow…thanks hestiny…that worked exactly like you said :grinning:
thanks osmc team for helping