Deleting all config from the OSMC TVHEADEND service (in the appstore) to start again?

#1

All - what commands are required to do this? The user ip address was changed inside the [ipaddress]:9981 and now I cannot login to the service.

For correct ip intialisation next time, what should it be?

Home network is 192.168.1.1 (router) with the Vero box set to 192.168.1.24 static IP. I did have 192.168.1.0/24 in the tvheadend service but couldn’t see any muxes/networks etc, and so I changed it to what (I thought) it was asking for (the router) and now can’t login…

0 Likes

#2

I have tried to stop the service, reboot and retstart the service but still cannot login to 192.168.1.24:9981. SSH still works fine with normal username and password for the device.

0 Likes

#3

Well, the most radical method is to start with a new tvheadend config:

  • SSH to the OSMC device
  • sudo systemctl stop tvheadend
  • mv /home/osmc/.hts /home/osmc/.hts.old
  • sudo systemctl start tvheadend

should let restart tvheadend in a virgin state.

You can also try before changing back user prefix for the accesscontrol:

  • SSH to the OSMC device
  • sudo systemctl stop tvheadend
  • cd /home/osmc/.hts/tvheadend/accesscontrol
  • each user entry in the tvh web GUI has a single file, edit it and change back the prefix line to:
    "prefix": "0.0.0.0/0,::/0",
  • sudo systemctl start tvheadend

Hope that is what you meant by

0 Likes

#5

You may find uninstalling tvheadend in the AppStore, followed by deleting the data directory

rm -r /home/osmc/.hts

then re-installing tvheadend easier to do. Then you can follow the installation instructions exactly again.

0 Likes

#6

Thanks that worked a treat.

1 Like