Deluge is slow and takes too much time to connect to peers

Hi,

I’m having a problem with deluge, as the title says it is working too slow (downloading and uploading) and it takes too much time to connect to peers. I installed deluged and deluge-web using apt-get and I made a service using this instructions:

http://dev.deluge-torrent.org/wiki/UserGuide/Service/systemd

I set it up to run as osmc user. Deluge is downloading to an USB drive that is auto-mounted at boot with this options:

/dev/sda1 on /media/RaspberryPi type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks)

I tried to mount it using fstab (defaults) with no positive results. All ports are correctly forwarded.

I ran wget to download an ubuntu image to this disk and everything looks good, also I sent a file via samba with even higher speeds. If I change the download directory to SD card nothing changes.

I’m using osmc on a RaspberryPi B with a wired connection. I come from Xbian and everything was working fine.

I don’t know what to do, any idea?

Edit: I forgot to say that I’m running osmc RC2, I did a fresh installation yesterday and everything is up to date.

I’m testing transmission, installed transmission-daemon and changed user to osmc in init.d script and systemd. Upload speed is way better but download speed is still slow, also the speed is not as stable as expected. These are the speeds I get:

Deluge(OSMC): U: 80KB/s, D: 1-2MB/s
Deluge(XBIAN): U: 1.2MB/s, D: 3-5MB/s
Transmission(OSMC): U: 1MB/s, D: 1-2MB/s (very unstable)

Connection: 100/10 Mbps

Both systems running at high overclock

I don’t have much advice for you on your current setup. I do have Deluge running on OSMC on a R.Pi2 and it’s working great. Not sure how you installed deluge but the one in the repos didn’t work for me for whatever reason. I recommend you try this:

Deluge for OSMC

Also, I’m auto-starting deluge with cron, not systemd.

Thanks for your answer, I will give it a shot. I think it’s working better now, I have been trying some torrents from different sites. When downloading public torrents deluge reaches the limit of connections (DHT and PEX disabled) and it isn’t able to download faster than 2 MB/s (the default limit is 200 connections), maybe the Rpi is overloaded. When downloading torrents from private trackers deluge doesn’t reach the limit (50-60 connections) and is able to download at 4 MB/s.

I tried to decrease the limit of connectios per torrent but nothing changes. Everything is set up with default options, I only changed the download folder.

These are the steps I followed to install deluge (I follow the same steps in every OS):

  1. Install packages: apt-get install deluged deluge-web (official repos)

  2. Make systemd services for deluged and deluge-web following these instructions: http://dev.deluge-torrent.org/wiki/UserGuide/Service/systemd (Change User and Group to osmc in both services)

  3. Start and stop both services using systemctl start/stop deluged deluge-web. This is needed in order to create the configuration files. You can enable these services if you want them to be started at boot

  4. Set up ThinClient following this: http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient

If anyone still follow the topic, last remarks may worth the read
https://discourse.osmc.tv/t/deluge-for-osmc/204/22?u=shamael