Denon AVR switches to OSMC input (likely CEC issue)

I am running OSMC on a RPi2. It’s connected to my Denon AVR. However whenever I switch on the Denon AVR the receiver will change to the RPi2 input even if I have chosen another one.

I have every option in the CEC adapter setting set to None or Off, except the ‘Enabled’ (obviously).

If I turn the Enabled off then this doesn’t happen. But then I lose the ability to control OSMC using the TV remote.

How do I fix this?

I suspect that Denon would be the authority to consult for a fix - but a search might suggest something else.
Some years back there was a similar problem with SCART connections, and there was one particular wire which, if ‘cut’, could be taken out of the situation, so that connecting that apparatus did not cause switching.

All my other inputs have CEC enabled but none of them grab the input of the Amp. Its only the OSMC input that does it.

That still doesn’t mean that the problem is in the RPi/OSMC/CEC setup.

I have a similar issue with my Yamaha amp. Around 5-10 seconds after turning the amp on, the input will switch to my Pi2, regardless of any other actions or input selection I have done in the meantime.

It’s rather annoying, but I haven’t managed to nail down whether it’s OSMC, the Pi, or something else plugged into the amp which is causing it.

Thats right. It happened to me on a previous Yamaha AVR too. When i add hdmi_ignore_cec then this doesnt happen.
But it seems to me that OSMC is ignoring the hdmi_ignore_cec_init
And before you ask, no i dont have a NOOBS install.

Where does OSMC store its Pi config. I edited the boot/config.txt file but i dont know if OSMC loads another version after boot.

osmc@osmc:~$ cat /etc/fstab
/dev/mmcblk0p1 /boot vfat defaults,noatime 0 0
/dev/mmcblk0p2 / ext4 defaults,noatime 0 0

/boot/config.txt is correct. Actually you don’t need to manually configure it, you can directly do it in MyOSMC.
And for me “hdmi_ignore_cec_init=1” works

OK I can confirm that the “hdmi_ignore_cec_init=1” works on my Denon amp.

I was on another input. Put in “hdmi_ignore_cec_init=0” and rebooted the Pi via ssh. The amp changes to the Pi input when the Pi boots.

Moved back to the other input. Put in “hdmi_ignore_cec_init=1” and rebooted the Pi via ssh. Now the amp doesn’t change to the Pi input.

In doing this and realised something else.

After I reboot the Pi and don’t actually switch to the Pi input. Restarting the amp will stay on whatever input I last shut it off on.
However if I switch to the OSMC input and then move away to another input. Then restarting the amp will go to the input I last shut it off with for about a second before the input automatically switches back to the OSMC.

So it’s almost like once the HDMI handshake has taken place between Pi and AVR then that has the highest priority on restarting the AVR.

hdmi_ignore_cec_init=1 has always been there by default on a new install of OSMC, so at some point you must have removed this, perhaps inadvertently in the Pi Config GUI.

I hadn’t changed anything this was a fresh default install of OSMC that was causing a problem.

I now ‘think’ I worked out what is causing the issue.

My AVR automatically switches to an Active HDMI input regardless. I noticed that if I had my Blu-ray playing and switched the AVR off, when I restarted the AVR on another input it would switch to the Blu-ray.
But this happens only if the Bluray player is playing something. It doesn’t happen if its simply powered on and stopped.

Strangely this HDMI behaviour doesn’t affect the Sky+HD box also connected to the AVR via HDMI. The AVR never switches to the Sky input automatically regardless of the Sky box power state.

So OSMC must be keeping the HDMI line active and so the amp switches to that input when it powers on.

I seem to have some success if I set the OSMC GUI sounds off and the screensaver set to Blank screen.

Nevertheless, that setting is already enabled by default on a clean install and always has been. Honest… :wink: The only reason you’re having the problem is because something somewhere has changed it.

Yes if you leave OSMC running then naturally the HDMI output remains on. Why would you think otherwise ?

So then why does the Sky+ box not behave the same way, that too is active on the HDMI. The AVR never switches to the SKy+ input.

Also when my Bluray is powered on I get the Pioneer logo on the screen which means there is video on the HDMI. But the AVR doesnt switch to it. It only switches to it when the bluray is actually playing something.

It’s been 3 days now and my fix of turning the GUI sounds off (and setting a blank screensaver) seem to have done the trick.

My theory is that when the AVR switches on, it turns the HDMI channel between it and OSMC on, that in turn makes something chime on OSMC and that makes the AVR think OSMC wants to play something and because it prioritises HDMI inputs over everything else, switches to the OSMC input even if I have turned another input on.

I’m having exactly the same problem (but with a Philips Soundbar). The only thing that changed in my OSMC setup is the November update and indeed I left the GUI sounds on this time. Will try to turn them off, see if it helps.

EDIT: it didn’t help for me. Whenever my soundbar switches on, the input gets switched to OSMC.