Denon AVR-X3400H no signal on other HDMI after using OSMC!?


I never had any problems with my Vero 4k since the last November upgrade(s). The Vero 4k works always without any problem BUT when I switch to an other HDMI-IN (SAT, Apple TV, Oppo UHD) AFTER using the Vero 4k I don’t have any signal on my TV.

The solution ist to turn off/on several times main zone and 2nd zone on the AVR and the other devices are working. I tried everything on the AVR (reset, firmwareupdate etc.) and also contacted the Denon support. They said that it is possible that a device can cause this issue (bad HDMI signal)

All the devices are up to date withe the latest firmware:

AVR main Zone - HDMI out -> Sony A1

  • HDMI 1 -> Dreambox 920 UHD
  • HDMI 2 -> Apple TV 4K
  • HDMI 3 -> OPPO UHD 203
  • HDMI 4 -> /
  • HDMI 5 -> Vero 4K

AVR 2nd Zone -> turned off

any help would be greatly appreciated.

best regards,

It seems unlikely OSMC would be causing the issue here.

When you switch over to another source is the Vero still powered?

If you suspend the Vero before switching source does the issue go away? Suspending disabled the TMDS clock.

Hi Sam,

yes, when I switch to another source the Vero is still powered. I tried also to power off the Vero before switching to other sources but didn’t help. The odd thing is that the Vero (HDMI 5) always works. I also have no issues on the other HDMI sources sind I use the Vero again.

Can you please post some logs when you have no signal?


Hi Sam,

the Vero always deliver signal, so should I post some logs from the Vero when the other sources have no signal? Which logs do you need?


If you suspend the device, it will turn off the HDMI TMDS clock (i.e. No Signal).


sorry, I don’t understand what I should do. Suspend the Vero and then collect some logs?

If you are suspending the Vero, it will not send a signal. I would suggest this:

  • Suspend the Vero (Power -> Suspend)
  • Switch to source that should work but doesn’t
  • Login to Vero via SSH and run grab-logs -A


ok thanks, I’ll do that and collect the logs.


Hi Sam,

question: can CEC from the Vero maybe make such problems?

No – I don’t think this could cause this issue.

Hi Sam,

I uploaded the log files when the Vero is in suspend mode at



From what I can see, this isn’t caused by OSMC:

  • You don’t have HPD locking on, which is good
  • The TMDS is being killed on Suspend, so the Vero isn’t sending a signal.

There must be something else that changed in your environment around the time of the November update. Perhaps a firmware update on another device?

Hi Sam,

thanks for the information!

Indeed I made a firmware upgrade of the Denone (AVR-X3400H). The support of Denon told me that it is the latest version from September. I can try to switch back to a old version.

Anyway it is strange that the Vero (connected at HDMI-IN 5) works always. I can try to connect the Vero to another HDMI. I let you know