Dependancy failed for local file system. After July update

I manually updated to the July release on my Vero this evening after finishing it came up to the osmc spash screen then after a long time displayed “Dependancy failed for local file system.” I pulled the plug let it sit for a min and plugged it back in only to receive the same results. So I downloaded the app and loaded the latest release of OSMC availible thru the app which was the June release. It went thru the install and powered up to xBMC no problem, again I selected to update to get the July release (shared database and the pi2 updated without issue so have to and want to :wink: ) This time I watched the entire process start to finish no errors issues or anything and from a clean install again same error at boot…

1 Like

Should also add that the network does not initialize so I can’t ssh in to get logs if there are any.

Could you take a picture of the startup errors on the screen then please. Also let us know if you have any external drives plugged in and what their configuration is.

At first I thought it might have been my cd drive so I removed that reformatted the SD card and reinstalled the June release with nothing but power hdmi and network. Booted fine selected update and after it finished same error. Then I tried it via command line and same results. Recreated the following error again for the 4th time by formating the SD card and selecting update in osmc.

Thanks. Will see if I can reproduce this. Are you using the 8GB Sandisk card supplied with the Vero ? If not what model of card is it.

Hi

I just downloaded the June update and ran an upgrade to the July one from My OSMC. I was using a SanDisk 8GB SD card, which is the same one you would have received.

I could not replicate this issue – is there any external media attached, and have you changed any settings, or is this a truly fresh install?

Sam

I’ve also tried to replicate this, but using an 8GB noobs (Samsung) card, and had no problems after a fresh install of the June release and then an update to the July release. The only device I had plugged in was a USB keyboard.

Do you have another SD card you could try ? If not, put your SD card into a PC and edit uEnv.txt on the fat partition - remove the word ‘quiet’ then save the file.

Then try to boot and this will disable the splash screen thus showing a lot more information about the bootup process. When it gets to the point where it gets stuck, take another picture.

This started out as a OTA update, but since then I have done multiple fresh installs with no changes and no peripherals attached.

Is there a NOOBS for the VERO? I thought that was for Raspberry PI only, my RPI2 updated with no problem its my Vero that is having issues.

Below is the screenshot of the boot error with quiet removed from the config file.

Ok that is failing to mount the fat32 /boot partition, which is considered by the system to be an essential partition, thus it won’t boot any further.

You didn’t answer my question earlier about whether you are using the 8GB Sandisk card that shipped with the Vero or whether you have substituted another card ? (If so what make and model)

The problem appears to be that after the update it can no longer read the SD card, possibly due to the kernel update. Can you try two things for me:

  1. Put your SD card back into a PC, and on the fat partition copy the file ‘vmlinuz-3.14.37-14-osmc’ over top of the file ‘zImage’ then safely unmount the disk then try to boot from the disk again. This will revert you to the kernel version from the June release.

If this works then it means the new kernel is not able to read from the SD card in which case we definitely need to know the exact make and model of the card as there may be an incompatibility.

  1. If you have another SD card available (or the original SD card if you are using a different one) please try a fresh install onto that card then update to see if you have the same problem.

Thanks.

I’m using the SanDisk 8GB SD card that came with the Vero, in fact the first time I’ve removed it is after this issue occured.

I copied that file over the top of the other however it would power up afterwards.

Can you please answer:

Does seems to be the crux of the issue? If so, and you’ve done these exact above steps with no customisation steps, then do let me know.

If you have another SD card at hand, then you can try that and we can start to rule out potential issues.

Sam

Sorry I missed a step, as well as copying vmlinuz-3.14.37-14-osmc over zImage, you also need to copy imx6dl-vero.dtb from within the folder dtb-3.14.37-14-osmc to the root directory of the fat partition over top of the file already there called imx6dl-vero.dtb.

If you haven’t wiped the card yet, please try that and it should at least try to boot again.

Edit: sorry could you add one more thing to what you are trying. Edit uEnv.txt again and on the end of the long line and separated by a space, add

loglevel=7

That will increase the debug logging of the kernel and may give more clues.

Sam that is the exact process I’ve followed going on 7 times now with the addition of formating the SD card prior so that the osmc installer will see it, to do that I’ve used both built in mac formatter and the SD foundations tool.

I’m looking for another micro SD card… they are all over the place when I don’t need one… but now god knows where in my house one is.

I will try the extra steps later tonight after I pick up and feed the kiddos.

Ok So I updated those two files and now it is booting again!

Here is the commands I ran in case anyone else is running into this issue until a fix is released. (Knowing Sam it wont be long lol )

Open Directory to the Fat partition of the SDCard. This will be different please verify and run proper directory name.

cd /Volumes/VeroSD

Backup original files, Completely optional and really not needed just force of habit.

cp zImage zImage_20150806
cp imx6dl-vero.dtb imx6dl-vero.dtb20150806

Overwrite the new kernel with the old.

cp dtb-3.14.37-14-osmc/imx6dl-vero.dtb imx6dl-vero.dtb
cp vmlinuz-3.14.37-14-osmc zImage

I struck out completely on finding a spare SDCard, If you still need me to test another SD card let me know and I can wipe my Pi2 microSD card. (I use a shared DB so its not that hard to reset up, just would prefer not to)

1 Like

Ok and the log level of 7 was useless unless to a log file, it writes everytime the system clock changes so a new line every tenth of a millisecond, saw some other messages fly by but completely unreadable.

I backed it down to 6 and captured the following log.

Seems like a busted card. Email sales@osmc.tv with your order # and I will send a replacement

S

Is it booting normally with the two files replaced or does it still get stuck ? I misread your first paragraph and interpreted it at first to mean it is booting normally now but on rereading I think you mean that it is still only booting as far as the screenshot - in which case the card is very likely at fault.

It works perfectly with the 3.14 kernel, but fails to read the SD card on the updated kernel. Right now I have it working on the 3.14 kernel with no issues, however I had missed your message asking for a screenshot of the error with logging turned up so flipped to the new took the screenshot and then flipped it back.

I can also confirm that it also does not work installing the July update directly with the install app. (Found link in other forum post)