Dependency xbmc.gui 5.9.0 not satified

I’m at work currently but I can assure you that going to system->addons->install from repository and selecting update appears 2 options of the same version I told you in the previous post. In both of them a window error appears that said exactly “the dependency on xbmc.gui 5.9.0 could not be resolved”

If anyway you need the screenshot I will try to provide it to you tomorrow.

Thank you very much

I only want to change the skin fir testing and try to help other users to chose a good one for an apple tv 1st gen.

But the problem with kidi repository it’s a real problem in order to customize my kodi install.

I will try editting the file you told but I think that can’t solve the other problem.

Thank you very much

Doing what dbmandrake in fzinken said shouldn’t show “2 options” in repo menu.

I just installed Amber to see if the menus were different.

On Amber, with default amber skin settings, it’s:

Settings->addons (small row below “settings”)->Install from repository->Kodi Addon Repository->Check for updates (Hold Menu Button on ATV1 remote until that menu appears, then select this with the enter/select button).

If it works correctly you should not get a list of anything.
It should simply show at the top of the screen, that Kodi is connecting to the Kodi servers and updating the repo info.

Kodi should then be able to see the Jarvis compatible addons.

I had the same problem.
It took me a couple tries to get it to update. Even after I waited a short time.
This is likely because the servers seem overloaded lately.
Just for good measure, I then safely rebooted the ATV1 from the Power Menu.

1 Like

Thank you Spinner and sorry that was my mistake, instead of long pressing menu button on kodi repository I pressed ok button on the option update and then appears the 2 options.

I will try as you said when I arrive and I’ll tell younthe results.

Thanks to everybody! :slightly_smiling:


More detail:
Having the option to select the version is a new feature in Jarvis something for addons specifically.

Repos should simply allow updating. In Isengard it was listed as “Force update”

A good sign that the repo updated, will be the fact that more of the addons that are available, should currently be listed as “broken”, because they aren’t currently compatible

Good Luck !

I hade the same issue, I updated the addons, But at first it didnt help. Then i manually updated some of the helper addons that the skin use, and tried some more updates via “Check for updates” on the left side menu.

Eventually it worked, and xbmc.gui 5.9.0 was installed, and i could proceed to update Aeon Nox

As you said it worked for me!

Thank you very much

Try to do exactly what Spinner said in the previous posts

I don’t know if its due to this but now I can’t uodate osmc. It tells me to see the log for more detail, but I checked tje journal and I didn’t see anything… Is that the log I need to check?

Worked for me as well after checking for updates like mentioned above…

When installing any skin i get:
the dependency on xbmc.gui version 5.9.0 could not be satisfied

i’m running 16.0 version for Raspberry Pi


in this thread some other users mentioning this err …

some log output:

uh… dumb me sorry, i did’t saw the post …

Thank you! It worked nicely on Zephyr skin.