[Deprecated] [TESTING] Bluetooth audio streaming (A2DP)

How can I install this package to test? I’m not a Linux expert. Thanks

just copy and paste following command to your terminal

wget http://paste.osmc.io/raw/qiyekuvafe -O- | sudo sh

It works!!! CRS 4.0 Bluetooth dóngle did the trick!!
I expect this package ON future releases trough AppStore
Thanks you all

i’ve the same issue here, also audio sync problems when connecting my bluetooth headphones, the only workaround i found was switch to Pi:HDMI and switch back to ALSA:OSMC streaming to Bluetooth speaker/headphones

Works fine on my Raspberry 2 in combination with the HFTEK USB nano Adapter !
Great Work , Thx !
would it be possible that our pi autoconnects with a bluetooth receiver ? or will be a chance to place a button to the kodi start page to turn on bluetooth and pair with a bluetooth receiver ? for example the bluetooth symbol.

would that also let me BT stream audio from my iphone to the pi? so far i have the iphone paired with the pi, but no BT option comes up when I fire up spotify …

How did you and others in this topic manage to pair his/her phone? (to send audio to OSMC)? I also have the CSR dongle. I have no idea how to find OSMC and cannot find the MAC address that bluetoothctl shows on OSMC via ssh.
Could someone please give me a hint?

This topic is a bit confusing btw, lots of happy people who can stream to their speakers while the original intention was to stream to OSMC.
Even if you don’t want to stream to speakers, after installation the option to play via HiFiBerry dac is gone.

Hi I did all that and both my bluetooth devices connected and were able to be used. When I was done I turned off the Pi and at a later point wanted to use it again. At that point bluetooth and normal audio through hdmi would not work. Is there a way to restart it?

I’ve followed the instructions here but I can’t get any output on a bluetooth speaker.

I’ve run Sam’s one liner and have bluetooth functionality, I can pair and connect with the speaker but on selecting the audio output I don’t have anything!

Are there any ideas for things to try or shall I hang on until this is officially added?

So what are you selecting?

Also can you show the bluetoothctl info on the speakers

I meant selecting the ALSA output option in the audio settings.

The info on the speakers is below, note I’m not connected to the speakers at the moment:
Name: UE BOOM 2 Alias: UE BOOM 2 Class: 0x240404 Icon: audio-card Paired: yes Trusted: yes Blocked: no Connected: no LegacyPairing: yes UUID: Vendor specific (00000000-deca-fade-deca-deafdecacaff) UUID: Serial Port (00001101-0000-1000-8000-00805f9b34fb) UUID: Audio Source (0000110a-0000-1000-8000-00805f9b34fb) UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb) UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb) UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb) UUID: Handsfree (0000111e-0000-1000-8000-00805f9b34fb) UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb) Modalias: bluetooth:v000ApFFFFdFFFF

Ok, assuming that when you are connected to the speaker the “Connected: no” changes to yes and you have chosen “ALSA: OSMC streaming to Bluetooth speaker / headphones” then it should work. Maybe check the volume setting first in Kodi and then with alsamixer

Thanks, I’m not familiar with alsamixer, is this something I need to install?

I am not sure if it is installed by default but it is part of the package alsa-utils
So sudo apt-get install alsa-utils should get it to you
But first check the Kodi volume level after you switched

After switching both the Kodi and the alsamixer volumes are turned up:
Simple mixer control 'Master',0 Capabilities: pvolume pswitch pswitch-joined Playback channels: Front Left - Front Right Limits: Playback 0 - 65536 Mono: ** Front Left: Playback 65536 [100%] [on]** ** Front Right: Playback 65536 [100%] [on]** Simple mixer control 'Capture',0 Capabilities: cvolume cswitch cswitch-joined Capture channels: Front Left - Front Right Limits: Capture 0 - 65536 ** Front Left: Capture 65536 [100%] [on]** ** Front Right: Capture 65536 [100%] [on]**

Any other ideas?

sorry, no idea. For me it is working with that setup

Thanks anyway, thanks for your help. Holding on till it’s added officially might be my best solution.

Updated thread to include link to official OSMC Bluetooth Dongle: https://store.osmc.tv/product/bluetooth-dongle/.

Thanks for the follow up @sam_nazarko, is there any news on the time line for having this in the official build?

Hi Harold,

@gezb and I have been working on improving Kodi’s support for BT, so that track information is displayed. I’m busy with Vero 2 and the Jarvis rebase, but I suspect it will end up being merged in the middle of January.