/dev/spidev0.0 missing after November Update

On my Raspberry Pi 2, /dev/spidev0.0 is not being created after the November 2015 update.

The spi-bcm2835-overlay.dtb is not present in /boot/overlays or /boot/dtb-4.3.0-10-osmc/overlays

config.txt contains:


1 Like

The kernel for Raspberry Pi is undergoing changes gonna ask @popcornmix if he knows what dtparam you should use to get spindev working again

I was able to get it to work by copying the spi-bcm2835-overlay.dtb

from: /boot/dtb-4.2.3-2-osmc/overlays
to: /boot/overlays

1 Like

it will be included in next update per default

1 Like

A post was split to a new topic: I’m a thread jacker who doesn’t know how to topic good

December-Update loaded today onto my RPi 2 - still no “/dev/spidev0.0” and no “spi-bcm2835-overlay.dtb” in “/boot/overlays” after updating.

The real problem is that it is not possible to copy the old file from “/boot/dtb-4.2.3-2-osmc/overlays” because it doesn’t exist anymore after the update.

The SPI overlay was added a few days ago and the kernel has since been rebuilt. Is this the correct one?

It would appear spi-bcm2835-overlay.dts does not exist anymore. This is why this issue began in the first place.

All I see for SPI is:

sam@sam-laptop:~/Code/Git/pi-linux/arch/arm/boot/dts/overlays$ ls | grep spi

I will check with @popcornmix on this matter.

1 Like

Thank you.

Unfortunately I’m nearly total noob according to Linux and stuff, sorry. The only thing I can tell is that /dev/spidev0.0 is used as output for Hyperion, which was broken for me since OSMCs November Update (I used the fix in this thread) and now was broken again after December Update (but the fix isn’t working anymore).

So far the only chance I see is to create myself a second SD-card with OSMC 2015.10-1 on it and extract “spi-bcm2835-overlay.dtb” from “/boot/overlays” of this older version to copy it to my actual OSMC on December Update.

Have you tried dtparam=spi=on in config.txt?

1 Like

I’ve the same problem that spi-bcm2835-overlay.dtb is missing causing my ambilight not working. Is there no other way than revert back to october update to fix this?? I dont feel I got the time for this…

It didnt…

It worked!

I didn’t expect that an OSMC Update would remove the dtparam=spi=on from the config.txt but it was gone. When I tried to check it I found out that I am also experiencing the “no access to RPi Config through My OSMC” issue on my RPi 2. So I put dtparam=spi=on into the config.txt manually via SSH and that brought back /dev/spidev0.0 and Hyperion is working properly again.

Thank you!


That overlay is not nessary anymore according to popcornmix so all you have to do is the dtparam=spi=on

reboot your pi and spidev should be active

Havn’t touched the boot/config file in ages but dtparam=spi=on is there. On the other hand, should i remove the dtoverlay=spi-bcm2835-overlay?

Ah, I removed both overlay line and dtparam and got it working again, thank you! Now only I thing left, getting my xb1 controller working with retromsc again… :stuck_out_tongue:

1 Like

Closing this thread if there are any other issues please reopen in a new thread.