Device name on router

I know this is not a huge deal but for whatever reason I can not get my Vero4K to show the device name in my router device list. All i get get is “unknown device” and an ip address. I have my hostname set as Vero4K and dhcp is on. Any ideas?

It’s possible your router looks up the MAC block instead of the hostname, or isn’t parsing our hostname via DHCP properly.

Yeah I have considered that. In this case I have all my devices having reserved
ip’s via mac address> I do this to keep track of the 30 some devices in my house that access the router either by wire or wifi. I would say that 90% of my connected devices be they wired or wifi show the name correctly. This being the case I can’t see it as this being the issue. Of course I am no guru when it comes to how routers handle hostnames from devices so you may be correct?

What do you think the issue is then?
I’ve checked, and we do send the hostname on DHCP requests.

Hahaha, I wish I knew, thats why I posted the question. As first mentioned it is not really an issue, just more of a curiosity as to why the hostname is not getting displayed. I will tinker some and see if I can get it worked out, if not nothing lost. Just as a fyi here are a couple of my settings.

from hostname…
osmc@Vero4K-osmc:/etc$ hostname Vero4K-osmc

and from hosts… localhost.localdomain localhost Vero4K-osmc

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouter

Yes I did edit the hosts file a bit but I had the same results before it was edited, that is why the edit.

If you change the hostname in /etc/hostname, you don’t need to adjust /etc/hosts, as we use libnss-myhostname to resolve this.

Not sure why the router doesn’t display the device. Perhaps they can elaborate on how they plan to populate that field.

Thanks for the quick feedback Sam, much appreciated. It’s just the OCD in me that wants to see the hostname displayed, it does not diminish the love I have for your product!

Just an update. The Vero4K clearly does broadcast it’s hostname as I can log into my isp supplied router with a app and it show correctly. The issue lies within my Telus ( isp supplied) routers gui.

Thanks again.

Well, I don’t know this Telus router but I would at least try first with a simple name like “myvero” … perhaps the bug in the Telos is

  • host name limited in length
  • not accepting capital chars
  • not accepting numbers
  • not accepting the hyphen ‘-’

In case “myvero” should work, it must be something like that.

All good suggestions but unfortunately none worked. My Telus (ISP) modem is in fact a Actiontec T3200M, which is pretty much locked down by Telus so there is not a lot of flexibility to try different things. I have pretty much resigned myself to the fact that I will just have to live with the way it works.