Dhcp-client connman configuration setup issue

I am a very happy long time user.
Pi2, latest release 1.0…
This is a bug report about either “Programs---->OSMC Settings----->Network”
or my understanding of same.

All was working, but I noticed that my OSMC box had no dhcp lease with my server (Lbuntu dnsmasq).
This was not a stable setup so I investigated. I am new to connman so I had to learn a bit.
Turned out my ethernet wired connection was configured to manual. Probably my doing.

I was unable to return to a dhcp managed connection using the OSMC Settings program.
(Possibly a bug, or me being confused.)

So I used a ssh prompt to do this:
sudo connmanctl config ethernet_b827eb397bd3_cable --ipv4 dhcp
(your ethernet_… service name will differ)

Now I have a proper lease.
Perhaps it would help if the OSMC Settings program displayed the full current state of the connection
as well as offering possible changes.


What error did you see when switching back to dhcp in the networking gui?

It already does exactly that. If you are currently using a static configuration you will see a screen like this that shows the current configuration:

To go back to using DHCP you would choose “Configure Network using DHCP”, which will bring up an Apply option, after choosing apply you will be back to DHCP.

I guess it would help me if a status line were added below “Configure Network using DHCP”
saying “Current config Manual:”

1 Like