Different IPs: OSMC addon vs ifconfig

Can someone explain this too me as I tried to figure this out but I couldn’t

I set static IP on OSMC addon but in “ifconfig” it’s showing a different one
Also it’s showing two IPs for the same MAC address in my router settings

hi @fernandog
does it still show the wrong ip after a reboot ?

Reboot worked. But i also set static IP in router. I will remove the static and router and reboot again

osmc runs python right? so it “scraps” the result of ifconfig, so how it would show a different IP?

the addon is python

underneath is should use the usual linux apps like ifconfig

perhaps that it doesn’t checks for updated ip, i have not looked at the code

What is weird is i recently installed OpenVPN, my other two rpis doesn’t had this issue
So I’m wondering if have anything related

Removing the static IP from router I get again different IPs:

just remember that OSMC uses connman instead of DNSMasq

VPN can be troublesome on OSMC seen plenty of uses try to battle with connman

recommend setting up a hotspot instead that they can connect to that connects to the vpn :slight_smile: less problematic

but I will enabled static IP in router again as It seems to fixed it. VPN and everything still working fine

1 Like