Difficulty updating OSMC

Hi All,

I have two older VERO 4k’s having difficulty with updates.

One is November 2020.11-1

I read the various help guides, nothing seems to be working.

Log is at -

Any suggestions?


Do a backup and reinstall OSMC.
And in future do updates at least once a year

1 Like

I have tried that, via an SD Card and USB, nothing happens on reboot.

Did you use the installer to image these devices or did you just copy the file? If that latter, that doesn’t work. The download link at the top of this page has a link to the installer.

Please show a screenshot of the USB stick / SD card so we can check that you imaged it properly.


Sorry, we mean a screenshot of the filesystem contents on your computer.


sorry I am a noob.

There’s your problem.

Move that osmc-installer.exe somewhere else on your PC. Desktop is fine. Run it, and follow the on-screen instructions. Point to the USB or SD card when prompted, and it’ll work fine.

This should also clarify things a bit better: Reinstalling OSMC - Vero 4K - OSMC

Any questions let me know. I’m going to bed shortly but if you’re still having a problem PM a phone number and I can walk you through it.


Thanks Sam, that worked perfectly.

I have another Vero 4k which has been in storage for ages and is running OSMC 20218.01-1.

I tried to do the same and nothing happened, do I need to do something different?

You need to re-write the USB/SD image, if you’ve plugged the same one in. This is to stop people re-imaging the same device over and over by accident.

So re-run that osmc-installer.exe program.


Thanks Sam,
I tried that and the update froze.
Any suggestions?

Can you show me a picture of what you mean by frozen?

This shows a corrupted filesystem but no evidence of the installer actually running.

Did the installer come up on this device?

Yes, it looked like it was working through the instal and then the screen went black and that came up.

Should I try another instal?

This has come up on the latest attempt

Try the other USB port - assuming this is a USB install.

Thank you for your detailed assistance, Sam.
All updated now.


Glad you are now up to date