Difficulty with network shares


I have added a new Vero V into a house that has an existing ubuntu server running standard SMB guest shares that serve 2 chromeboxes running current versions of LibreElec.

I copied my sources.xml file along with my playlists that use “path contains” to the Vero when I set it up and everything worked flawlessly for a few days without any issues. Now all of a sudden on (only) the vero, via skin shortcuts or directly through the file browser, 2 of my paths don’t display anything and my log is filled with this:

2023-11-29 19:01:59.102 T:3100 info : SMBFile->Open: Unable to open file : ‘smb://’ unix_err:‘15’ error : ‘Is a directory’
2023-11-29 19:01:59.102 T:3100 error : CFileCache::Open - smb:// failed to open

If I set the content type back to none and purge the database I can see and browse/play everything. I tried adding a seperate path to the same location to my sources and it’s the same thing… it’s fine until I set the content type and try to scrape the directory and then it can’t open any of my folders. For what it’s worth I use the local metadata scraper only.

The chromeboxes are still fine and nothing has been changed on the server or with the vero settings/configs. Can anyone advise how I can troubleshoot this further? I’ve rescanned the paths, changed the content type back and forward etc and had no luck. It’s like the Vero has just suddenly decided it can’t browse SMB shares any more.

Edit - Note for what it’s worth I setup a totally new SMB share as a test. Works fine on the chromeboxes or a pc (with or without content type set) and fine on the vero when content type is set to “none” but the minute I set the content type to “tv” it stops working on the vero and I get a log full of errors. If it hadn’t worked for those first few days I would just assume it doesn’t support samba properly but that’s clearly not the case.

Edit 02 - I really don’t want to learn how to use fstab or autofs, change my server to NFS shares etc. I’m an old man now and spending hours tinkering in a shell to get something working doesn’t excite me anymore… I just want samba to work the way it works on other devices that run Kodi.

Edit 03 - so I caved and setup an NFS share on my server… works fine from my chromeboxes, doesn’t work for the Vero. I get this in the log:

error : Read - Error( -14, read call failed with “” )
error : Process - <nfs:// Show Name/> source read failed with -14!

Can someone please provide some guidance or suggestions? I am at a complete loss.

What exactly are those two file paths? It is a bit hard to advise with limited details. Some logs might prove helpful as well.

The file path doesn’t seem to matter… I have lots of different ones (even created some new ones) but the minute I set the content type to tv the smart playlists stop working. I can still see/play the items in the path from the root TV node but not from my smart playlists.

I did a complete reset on the Vero and recreated the shares and all of the above errors are gone from my log but the issue itself remains: I use smart playlists with the PATH CONTAINS rule to sort by folder on my SMB shares. This all works flawlessly on my chromeboxes but not the Vero. On the Vero Movies are fine but if the content type is set to TV then when you browse into the playlist you get an empty list and nothing written to the log file (even with debug mode on).

Is there a way I can make the log file capture even more detail? IE exactly what is happening when you browse into the relevant playlist? I’m not trying to be obstructionist… there’s just nothing abnormal in the log at all since the reset.

FWIW this guy had the exact same issue and it was never resolved: Smart playlist can't find files - #6 by yakes

The way I use smart playlists is pretty niche but it is supported by kodi and works perfectly on my chromeboxes and windows 10 PCs so this really does feel like some sort of odd osmc/vero bug.

The playlist only works from a library and this problem you have for some reason is keeping you from actually scraping this source into a library. This explains the playlist not working doesn’t it?

Now as to the library disappearing that is a bit of an odd one. The reason why it would disappear from videos>files when you set the scraper is more likely than not because you have the option set in Kodi’s preferences (I think it is the default setting) to replace file names with library titles. Thus whatever is messed up with the scraping is somehow creating blank entries in the library or putting in some flawed data in the database and that option is not allowing you to see the files at all.

I don’t think I’ve ever seen or read of anything close to this but I have to suspect that it has something to do with your nfo files. How this would affect Kodi running on OSMC and not a different Kodi client I really don’t know, but I would suggest to turn off the replace library titles option in Kodi’s settings, and set the scraper for just a single TV show in that problem file path the TMDB scraper and see what happens. It will still use the nfo file but it may act different to the local information only scraper. If it is still messed up bring up the information window and hit refresh choosing the option to ignore local data and to scrape online. Let me know how that goes and we can figure out next steps. If it is tripping up on the nfo file I’d be interested in a copy of one for the show itself and one episode.

On a side note, sorry about the delay in the response. Editing your original post doesn’t bump the thread so I had no idea you had added more information as requested. As for the logs showing more you turn on debug logging to get them to be more verbose which is in settings>system>logging>.

No that’s what’s odd… the content does appear to scrape into the library and I can play it if I go into the video node and select TV Shows… everything is in there, at the exact path I added (that’s the only way I can currently watch anything). The smart playlists just can’t see anything.

I was wrong about the errors. They are still there but I don’t think they are the issue… here’s one in it’s entirety that was generated when I tried to add a single TV show folder.

2024-01-05 19:26:30.381 T:3015 info : VideoInfoScanner: Starting scan …
2024-01-05 19:26:30.522 T:3015 info : SMBFile->Open: Unable to open file : ‘smb://USERNAME@’
unix_err:‘15’ error : ‘Is a directory’
2024-01-05 19:26:30.522 T:3015 error : CFileCache::Open - <smb:// x Family (2022)/> failed to open
2024-01-05 19:27:11.340 T:3015 error : Parse: Could not find scraper function GetArt
2024-01-05 19:27:11.340 T:3015 error : Run: Unable to parse web site
2024-01-05 19:27:11.381 T:3015 info : VideoInfoScanner: Finished scan. Scanning for video info took 41004 ms

I added that same path on one of my chromeboxes and I got the same error in the log but on the chromebox the smart playlist displays these files correctly and I can play the show through my old smart playlist or a new one that I just created. Following the exact same process on the Vero results in an empty playlist.

You might be onto something with the NFO files. I would have bet money that wasn’t the issue because they are generated by various different programs depending on how I download them and I created the NFOs for Spy X Family using the latest version of MediaElch today which should absolutely be creating Kodi compliant NFOs.

Having said that I tried your suggestion… I added Spy X Family and used TVDB to scrape it.
The same error above showed up in the log file but the smart playlist on the Vero works for this title only exactly as it does on my other installs.

Any idea how we can troubleshoot further?
I have literally thousands of NFO files and it’s not pratical for me to use the online scrapers or redo all of my local NFOS.

EDIT - I turned off the replace title with filename setting… it made no difference.

My suggestion at that point in troubleshooting was to provide me a copy of the nfo for one of the shows as well as one for a single episode for that same show. What I would have done is first used that to setup a one show library on a virgin profile recreating the environment the best I could with the information provided and see if I could reproduce the condition your seeing. Assuming that I did I would then pull the nfo files and setup the online scraper that matches the metadata provider that was originally used as should have been discoverable by browsing said nfo file. I would have then exported this online scraped Kodi library to individual files which would then give me a nfo file that is working that I would then use a diff application to compare it to the one with issues. Once I identified a possible errant tag I would then just manually edit that into the good nfo, refresh the show, and check to see if it breaks. Once I was able to identify where the problem came from specifically then, and only then, can possibilities for fixing the nfo files become discoverable. If the fix is a matter of swapping some known value with a different known value in the nfo files then it isn’t beyond the realm of possibilities to do a bulk edit of the nfo files.

As for the error 15 your seeing in the logs I really don’t know what is up with that. If it isn’t happening with other sources I would take a hard look at your sources.xml (and passwords.xml file if you have it) and see if you can spot anything different with that entry. That is one of the things I would have checked if you had provided logs along with making sure a path substitution isn’t being used that didn’t get mentioned that could be complicating the issue.

ok… I know how to upload the logs and I’ll do that.

How do I get you the NFOs?
I’ll also send you the sources and playlist files so you can confirm that it all matches.

You could use a upload site of your choice or just use paste.osmc.tv and copy/paste the text in the fixes to that site and click the save icon in the top right which will give you a url to access that text dump. The sources.xml is one of the things included in the default log upload options but if you have a passwords.xml file as well you can manually edit out your credentials from that and send it along if you think there is a possibility that there is an issue with the file paths. That file does path substitution to insert credentials to entries in sources.xml so it might factor in to that error you were seeing in the Kodi log. Not sure you have it though as you said you were using guest credentials.