Dim Screensaver does not undim

#1

When pausing a video, after a set time screen dims, the when clicking on remote, screen does not undim! video can play but stuck dimmed.

relading skin via kodi-send --action=“ReloadSkin()” brings briteness back

also reproducable going to screensaver page, setting dim as screensaver, click preview. screen dims, when a button is clicked it does not undim.

i can still navigate the system, but everything is dimmed out

#2

We need more information, like first, what version of OSMC. Second and really important is the platform; Pi or Vero.

Since many people use Dim (myself included) it’s not likely the problem More likely is a addon causing the problem.

#3

2019.5-1 Vero 4K+

#4

I’d suggest then that you supply logs

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

#5

enabled logging, rebooted, now dim works fine! Strange…

if it happens again i’ll let you know

#6

Had this issue too with raspberry pi 3 b+. Goes away on restart. If comes back I’ll try get a log.

#7

I keep getting this issue that videos will not undim after I resume the video. I have tried getting debug logs, but a reboot seems to solve the issue for several days until it comes back eventually. Can I keep these debug logs running for several days until the issue happens again?

Reloading the skin always seems to solve the issue.

I am using Vero 4K. I am on the most recent version of OSMC, and this issue started happening right after the Leia update.

#8

Yes.

#9

This has happened to me also, once or twice over the course of 3 months or so. Rebooting fixed it.

#10

Is rebooting required after turning on debug logs. I am having a challenge capturing this issue since a reboot fixes the issue, at least for several days. We use the Vero daily for watching shows/movies, so I hate that debug info at the top of the screen while I wait days for the issue to reappear.

#11

You can make/add to an advancedsettings.xml file to turn on debug logging without the overlay

<advancedsettings>
  <loglevel>1</loglevel>
</advancedsettings>

You would probably want to remove it after you were able to capture the logs you wanted.