Disable 2.4GHz?

My WiFi AP only supports AC on 5GHz. My Vero 4k defaults to 2.4GHz. Is there any way to disable the 2.4GHz radio on the 4k?

the best way is to disable the 2.4GHz on your router. If your network only sends a 5GHz Network, vero can only use this network.

But if your router does not support 2.4GHz, there should be no way for vero to connect to a 2.4GHz network i think…

Unless you connect to a neighbouring network; but it won’t do that automatically.
Just connect to the 5Ghz network in My OSMC

I don’t want to disable 2.4GHz on my whole network, I am just looking for a way to force the Vero 4k to use 5Ghz. For some reason, it seems to prefer 2.4G and I have to jump through hoops to get it into 5G mode. I found some references to using IW command, but I can’t get it to work for me.

The best way is to have a separate network name for 5Ghz and 2.4Ghz.
I think if you use connmanctl services; you’ll see two slightly different service names for 2.4Ghz and 5Ghz.

I seem to recall that you can tell wpa_supplicant to use specific frequencies but it’s all a big hassle and can so easily be overcome by following Sam’s advice and having two different SSIDs.

Well, I can’t mess with my network, but I can look into wpa_supplicant to see it there is anything there that can help me.

If you want to try it out, you need to look at wpa_supplicant.conf https://w1.fi/cgit/hostap/plain/wpa_supplicant/wpa_supplicant.conf

There’s freq_list and scan_freq . I suspect the former might be the one for you but you’ll need to experiment.

If you go down this path, I suspect you’ll also need to change /lib/systemd/system/wpa_supplicant.service to tell it to read the conf file.


On my router, the 5ghz radio has one ssid, and the 2.4ghz has a different ssid.
So, it’s just a matter of defining which ssid to connect to in Vero4k network settings.
I renamed each ssid like this

Problem Solved…

I didn’t initially look into wpa_supplicant as I assumed that this would be for authentication and my network is open. I explored iwconfig and iw commands first. With these, I could get lots of useful information like the BSSID of the 5GHz transmitter. However, the Vero did not seem to honor the commands to use that BSSID. So, I looked at wpa_supplicant and found out that it is more than just for authentication. My first several attempts had no effect. When I finally tickled something that had an effect, it disabled wifi altogether. My conclusion was that, if you want to mess with it, you have to do everything manually. So, this will be a bigger project. Time to set it aside.

Since I am replacing an OdroidC2 with the Vero 4k, I was assuming that the the slower Ethernet (100 Mbps) was this issue with the constant pauses for buffering. But, I realized that the OdroidC2 replaced a Raspberry Pi2, which also has only 100 Mbps and I didn’t have the problem with that. So, something else must be going on.

I had an anomaly when I first set my Vero 4k up. In going through the initialization screens, it asked about setting up for a SQL database (which I use). I entered the information, but I kept getting an error that not all of the information was entered. Finally, I gave up because I knew that I could set this up in my advancedsettings.xml file. I did that, and everything seemed to work, except for the poor network performance. All of my media is on a NAS.

I decided to start over with a fresh copy, so I re-flashed the image to the Vero 4k. At that point, I had no more network issues with my Ethernet cable. My conclusion was that something got set up incorrectly and was chewing up my network bandwidth. Home free, eh?

Not so quickly. My next problem was with CEC. I had a second Raspberry Pi2 on my HDMI-CEC network that was issuing commands (via cec-client) to set everything up correctly. That was no longer working as long as I had the Vero 4k on the bus. I remember reading on the forum about cables, so I decided to use the cable that came with the Vero 4k. The one that I was using was HDMI1.4, but I thought that was sufficient. With the Vero 4k supplied cable, the raspberry pi and all of the other boxes could talk to each other, but not to the Vero 4k. I did a scan using cec-client on the Vero 4k and the only device that it saw was itself. I concluded that the supplied HDMI cable was defective. I replaced it with a HDMI 2.0 compliant cable and now everything is working. I can now use the Vero 4k to handle all of my setups using cec-client, something that I was unable to do with the previous setups. So, now I have a simplified system.

Bottom line: Issue with original OSMC image on the Vero 4k and bad HDMI cable. That was disappointing, but in the end, I have a wonderful box. My S.O. is the prime user and she has had no complaints so far.

The cable doesn’t work for all users; not sure why. It’s an HDMI 2.0 certified cable.

Happy to send you another if you’d like, chuck me your order # in a PM


Not necessary. I picked up a 1.5 ft cable for less than $3. Perfect length for my setup.