Disable CEC

Is there a way to disable HDMI CEC on the Vero 4K?

Long story short, I’ve been round in circles trying to do this in the past and never managed to. Wondered if things have changed and there is now a simple way to truly disable CEC?

It causes many issues in my setup.

Cheers.

Hi,

Its under Settings - System - Input devices - Peripherals - CEC Adaptor

Thanks Tom.

Thank you. This setting was giving my AVR serious grief on the past but seems to be working fine now.

Great.

1 Like

Your directions worked fine but I’m sad to say HDMI CEC on the Vero still has issues.

Even with this disabled it causes sometimes my whole system to fall over. Every time I isolate it to the Vero. It doesn’t happen al the time (seems related to power cycling) but enough to make my setup unreliable (which I then get it in the neck for!)

Others in AVForums have reported exactly the same.

I have raised this before with Sam but I’m guessing it’s hard to fix.

I’ve ordered one of those CEC HDMI less adapters and will try that (hopefully 4K HDR will still work through it).

I’m not aware of any major problems with CEC at the moment. Is it causing your device to lock up?

Sam

It’s actually the impact on other devices.

Every so often CEC on my Denon AVR stops working, and consequently the ARC return audio from my TV. This manifest as an “Audio system communication error” message on the TV, as well as CEC type behaviour (auto on off etc) failing on all devices.

If I unplug things one by one it is always - without fail - unplugging the Vero that causes everything to work again (ie my TV, AVR and 4 other devices). I plug the Vero back in, CEC stops working throughout the other devices again, I unplug it and things bounce straight back to normal. So 100% the Vero is part of the cause.

At least one other member on AVForums has reported exactly the same issue (I could probably find the post if of interest). FWIW some other AVForums members have reported the same issue with the SHIELD TV; don’t know if that might point to some shared hardware.

This happens regardless of whether CEC on the Vero is enabled although does seem perhaps related to power cycling (ie after turning plug off on at wall it’s more likely to
occur although I’m not sure).

I was in direct email correspondence with you about it at one point but I do sympathise that it could be difficult to diagonose especially if it’s some weird interaction between the Vero and other devices.

Do you think it’s possible I have a faulty unit?

If nothing else is playing up, probably not.

Does the issue happen only when Vero is connected?

Sam

In hindsight I agree it seems very unlikely to be a faulty unit - plays flawlessly otherwise and this seems very much like a software (or firmware) issue

Yes - I have only seen this happen when the Vero is connected. It has been disconnected for a week while I await the CEC less adapter and zero issues.

If anybody else is reading this with the same issue - the Vero still seems able to output 4K HDR through one of the Lindy CEC less HDMI adapters (they have the pin removed which the CEC signals are carried on).

It was weird to start with - outputting at 1080i and the resolution jumping around but after a reboot it seems to work. And now I it will be impossible for the CEC issues to recur.

Keep us posted