Disable ps3 home key?

Okay, this is a little arcane, but I’ve tried the obvious things and they didn’t work.

I’m running on an RPi3. I installed RetrOSMC and paired a PS3 controller (Dualshock 3/Sixaxis) via bluetooth. After that I noticed that it was also able to control Kodi, which was nice. This was some time ago.

One of the things that’s been bugging me the whole time is that the “home” button on the PS3 controller causes Kodi to return to the home screen. This is annoying because if I want to turn off the controller I have to hold the home button for several seconds, so if I start a video and then want to turn off the controller there are shenanigans.

I’d had enough of it tonight and I decided to fix it. I got on the wiki and grabbed a copy of the default joystick.xml, moved it to the appropriate directory and removed all the entries. I rebooted the Pi and turned on the controller, but the button still makes it go to the home screen.

So I figured that since I don’t want that button doing anything ever, I could just remove it from the controller profile. I went into the settings menu and into the controller config, but there’s no way in there to unmap a button. I tried picking the relevant entry and letting it time out, but it didn’t change anything.

Any advice?

Enable debug log and check what actually is happening when the home button is pressed than you can work your way back from there. You then should be able to adapt it with a keymap in userdata/keymaps.

23:21:16.592 T:1815704560   DEBUG: BUTTON [ 16 ] on "PLAYSTATION(R)3 Controller" pressed
23:21:16.593 T:1815704560   DEBUG: FEATURE [ guide ] on game.controller.default pressed
23:21:16.608 T:1958825984   DEBUG: Activating window ID: 10000
23:21:16.722 T:1815704560   DEBUG: BUTTON [ 16 ] on "PLAYSTATION(R)3 Controller" released
23:21:16.722 T:1815704560   DEBUG: FEATURE [ guide ] on game.controller.default released
23:21:16.862 T:1958825984   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
23:21:16.874 T:1958825984   DEBUG: ------ Window Init (Home.xml) ------

Well, that’s indeed what it’s doing.

Hang on, I’ll try adding an empty entry for “guide” in joystick.xml.


The empty entry fixed it. I guess since there was no entry it was referring to whatever is the default setting instead of assuming it should just not do anything.

Oh well. Thanks, fzinken. :slight_smile:

No worries, have you done this in a keymap file in .kodi/userdata/keymaps? Otherwise will be overwritten next update.