Disabled "Show empty TV shows" not working correctly

#1

Not sure if my problem is OSMC or Kodi related one, but the following happens:

I have “Show empty TV shows” disabled here:

When I first enter from the main menu to TV Shows, I can all my shows are listed, even the empty ones (e.g. the first one):

I can then navigate to the empty show, it will show no episodes:

And when I navigate back, the empty ones are now disappeared:


It doesn’t matter if I went into an empty show or one with episodes, a back navigation always fixes the listing (the empty ones are hidden), but when I go back to the main menu, and re-enter TV Shows, the empty ones are coming back again.

I expect not to show any empty TV shows even when I am entering from main screen.

Version: OSMC 17.2 on Raspberry Pi 3

Empty TV shows not hidden
#2

Have you rebooted/restarted kodi since changing the setting?

#3

Yes, multiple times. This has been there in fact since the first v17 update - v16 was ok.

#4

So are we sure that this isn’t a Kodi issue present on all platforms running v17? Not just an OSMC issue?

#5

Just gave a try to Kodi (17.3) on Windows (via Store installation), the empy items are hidden on the first try there.
I don’t say it is not present in Kodi but this may be related to the OSMC skin/default TV shows link from the main menu (?)

#6

We do use a slightly different link to TV Shows than Estuary - library://video/tvshows/titles.xml as opposed to library://video/tvshows/titles/ - but this shouldn’t cause any issues, as ultimately they’re both just different ways to link to the same library node (ours is a little more explicit because of the skins utilisation of the Skin Shortcuts script). It would be interesting to know if you can reproduce the issue with Estuary on your OSMC box - if so, then it may point to an issue with how Kodi/OSMC handles explicit links to a library node. If not, it would point to issues elsewhere.

#7

Tried Estuary on OSMC, that was working fine. After this I tried again with different settings on the OSMC skin (flatten hiearchy Y/N, show empty tv shows Y/N, rebooting after changing the value), but with Show empty TV shows = N the same issue is still on.

#8

I recently moved from the Vero 1 (OSMC/Kodi 17.4) to the Vero 4k (same version).
On de Vero 1 this probem didn’t occur but on the Vero 4K it is as described above.
So It looks like platform (SoC) related.

Has anyone any luck with solving this ?

Tia
Leon

#9

Are you sure Vero 1 was on 17.4, and did you / can you test this feature on Vero 1?

OP is reporting this problem on Pi 3, so it may not be tied to an individual platform.

Sam

#10

I update to the OSMC august update before switching to the Vero 4K so I was on Kodi 17.4
And I never had the problem on the Vero 1.
On the Kodi forums there are more problems as these al started with Kodi 17.x.

May the problem occurs because of a new device that uses the shared MySql Video DB ?
I could try a fresh start with a new db this weekend ?

greetz Leon

#11

There is a library issue in 17.4 it seems. I’ve built a potential fix in the staging repository

Sam

#12

How do you use the stage repository ?

I can’t find a how to or something.

#13
#14

I would have posted the instructions yesterday, but the staging repository is a little bit choppy right now because of some UDisks changes I am making to prepare for the transition to Stretch.

#15

Can you let me know when the staging repo is back because I get an error (Sub-process /usr/bin/dpkg returned an error code (1)) when updating ?

#16

I’ll let you know. The UDisks transition is taking a bit longer than expected.

Sam

#17

On advise from Sam waited until the September update where the fix should be added to.
But no change with the september update.
There are more reported issues with this on Kodi 17 but I had no problems on the Vero1 Kodi 17) and no problems on the Pi 1 (Kodi 17) ?

#18

The library fix got a positive report.
This seems a different issue however and might need reporting to Kodi

Sam

#19

I did the OSMC october update (kodi 17.5) but it is not resolved.
Any idea how to get this fixed (it still is only a problem on the Vero 4K) ?

tia
Leurb

#20

Does it happen with all skins?
Have you experienced the problem with a fresh library?

Unfortunately I’m not sure what the issue could be presently

Sam