Disabling AirPlay, Raspberry Pi I, causes locked screen

So, I’ve had this issue a few times. When I’ve updated my movies, but more recently, when I’m trying to disable AirPlay by default. It causes my Raspberry Pi to lock up, as well as my computer to freeze for some time. If I’m watching a movie, it will stop the movie, and go to the home screen, and screw everything up.

I’m having difficulty following your question - you say that your Pi freezes when you try to disable Airplay - where ? In the preferences settings in Kodi, or do you mean that you’re trying to disconnect from the sending device ?

In the second part of your question you say disabling airplay will stop a movie playing - why wouldn’t it ?

When you say your Pi is locking up, do you mean you can no longer even ping it or connect with ssh, or just that the Kodi user interface is frozen ?

Please explain precisely the issues you are having, also please provide a Kodi debug log that was taken when the problems occurred.

My apologies, I wrote this late last night, and was quite tired. I’ll try to explain it better for you.

When I try to disable AirPlay in the preferences settings within Kodi, that is where I get the freezing.

When I start my MacBook, and anything with sounds comes on, even when my MacBook Pro is not outputting to the Raspberry Pi, whatever is playing on the Pi automatically stops, and I get kicked to the home screen of Kodi.

When I say the Pi is locking up, I’m referring to Kodi. I can make commands with my Kodi Remote (I have not tried SSH from another device), but the commands do nothing, and I sit on the “settings” page.

This is ONLY when using the Kodi Remote (so perhaps that’s the issue, I’m not sure), because when I try and do it with my keyboard, I can disable just fine.

This sounds like you may be accidentally disabling the web server or ‘Allow Kodi to be controlled by other devices’ setting.

Why are you doing this?

This confuses me. Am I right in thinking you want to periodically use AirPlay? If this is the case, then just turn it off from the device sending the stream (click the triangle and untick OSMC). Toggling on/off seems like a lot of hassle.

Either way, we’ll need a Kodi debug log to find out what is going on


Did you read the first 3 posts at all?

It’s when I’m trying to disable AirPlay

Because every time I boot my MacBook up, and my Pi is on, Kodi tries to connect to my MacBook, without me assigning the output of my MacBook to the Pi.

I don’t want to use AirPlay at all, it was enabled by default, and when trying to disable AirPlay on my Kodi via the App on my iPhone through the settings on the Pi itself, it causes everything to lock up.

Where can I find a Kodi debug log?

Hi Adam,

Please understand that I read hundreds of questions a day and do sometimes miss things. I only read your second post as your original one seemed to be lacking further details.

What do you mean by this? AirPlay will only output to an external audio sink if you specify as so. A screenshot will help here.

Ok – understood

Please search


You’ve got that back to front - Kodi doesn’t connect to your MacBook, it is your MacBook that is for some reason attempting to connect to Airplay on Kodi. Kodi is the server and the MacBook is the client.

Don’t try to turn off Airplay in Kodi while there is an active Airplay connection - I think there is a known bug that can cause a crash in these circumstances.

So try the following:

Shut down your MacBook. Reboot OSMC. Immediately go to the Airplay settings in Kodi and disable Airplay while the MacBook is still off. This should not crash.

1 Like